An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Previous Thread
Next Thread
Print Thread
Disk not properly ejected
#62522 09/06/22 02:43 PM
Joined: Dec 2009
kevs Offline OP
OP Offline

Joined: Dec 2009
This is gone from fluke to every few days:

https://imgur.com/a/ANnofVF

I'ts one of the two new 8TB Seagate got, going into directly to the back of the new mac mini.

The disc is working fine and mounted when I see the sign at 7am..

So it's a nuisance to see/ dismiss the sign, will it be worse that that? The disc is just outside of it's 30 easy return. It's the main Data drive.

The other new Seagate 8TB not doing this nor, the older 5TB Seagate, thanks.

Would bother contacting Seagate? or just live with it? Worse happen is Drive X will one days saying going downhill? Opinionos?

Re: Disk not properly ejected
kevs #62526 09/06/22 09:22 PM
Joined: Aug 2009
Likes: 6
Online

Joined: Aug 2009
Likes: 6
An improperly ejected disk is vulnerable to data loss, so if the problematic drive holds critical info you might want to move the info to another drive and use the problematic one for a less important purpose.


The new Great Equalizer is the SEND button.

In Memory of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: Disk not properly ejected
kevs #62528 09/07/22 05:03 PM
Joined: Aug 2009
Likes: 7
Moderator
Offline
Moderator

Joined: Aug 2009
Likes: 7
First and foremost I agree with Artie that you should not be using the disconnecting drive as your primary data drive. TO PROTECT AGAINST POSSIBLE IMMEDIATE DATA LOSS Use the other 8TB drive as your data drive, or even better switch to using your internal drive for your "Data" volume. Your 8TB USB HDs are much better suited for archival (long term, seldom accessed) storage.

Looking at possible causal factors for the disconnects, there are several distinct devices involved. Listed roughly in physical connection sequence from the drive to the computer they are...
  • The disk drive in the enclosure {If the issue involved the disk drive mechanism, the disconnects would show up in the S.M.A.R.T. values and reported by DriveDX, so I would rule the drive itself out as a suspect}
  • The SATA connector connecting the Disk drive to the enclosure electronics
  • The Bridge chip that is the transitions between the internal SATA and external USB ports. {In the early days of external drives this was often an issue, but has largely disappeared as the standards have evolved}
  • The power supply for the enclosure/drive. {Not highly likely, but a possibility}
  • The connection between the enclosure and the power supply. {Easily checked}
  • The cable between the power supply and the power source. {loose or faulty plug, also easily checked}
  • The power source. {some devices are more sensitive to momentary power interruptions or spikes than others, but almost impossible to diagnose. (I once had to have a recording device installed by an electrician to prove this as a causal factor)}
  • The cable connecting the drive to the computer {a reasonable suspect}
  • Any connection adaptor(s) {a reasonable suspect}
  • The port on the Mac mini {USB connections do come loose}


Accurate diagnosis could take weeks or months to perform so you must be patient. PERFORM THE FOLLOWING ACTIONS ONE AT A TIME and allow several days for a disconnect to occur before trying the next. When the disconnects cease or begin to occur on a different drive, you will know you have found the source of the problem.
  1. Switch to the spare 750GB on your internal SSD as your data volume.
  2. Physically disconnect and reconnect both ends of every cable including all the power cables and any connection adaptors.
  3. Switch the USB connecting cables between the two 8TB drives.
  4. Reconfigure all of your USB connections, ie. any daisy-chained or hub connections,


"Sacred cows make the best hamburger"

- Mark Twain
Re: Disk not properly ejected
joemikeb #62529 09/07/22 05:51 PM
Joined: Dec 2009
kevs Offline OP
OP Offline

Joined: Dec 2009
Thanks Joe good overview. Ok I'll detach all cables first and reattach firmly.

I think that covers 80% of your post.

This is brand new 8TB for image data. (I just moved my doc data to the internal SSD)

The other brand new 8tB was for TM, so I could (tediously) swap those down the road. However, my backup system 1x day SD, and crashplan in cloud , is pretty good so probably could live with it... (the danger is you could lose work did during some day's work).... I think unlikely.. let see how much continues... take notes!)


Moderated by  alternaut, dkmarsh, joemikeb 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Release build 20200307)
Responsive Width:

PHP: 7.4.25 Page Time: 0.017s Queries: 23 (0.012s) Memory: 0.5872 MB (Peak: 0.6480 MB) Data Comp: Zlib Server Time: 2022-09-28 12:42:19 UTC
Valid HTML 5 and Valid CSS