An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#8944 - 03/19/10 03:54 PM eMail hazard
joyss Offline


Registered: 09/21/09
What is the purpose of the black box surrounding my replies to email posts?
It is very difficult to work around it. Thanks. (*_*)






Edited by joemikeb (03/19/10 07:58 PM)
Edit Reason: Post moved from Mac OS X 10.6.x to Networking which is the proper venue for email related issues.
_________________________
(*_*)
iMac
OS 10.6.4

Top
#8949 - 03/19/10 08:00 PM Re: eMail hazard [Re: joyss]
alternaut Offline

Moderator

Registered: 08/04/09
Would you mind elaborating a bit by providing some more details like eMail client, OS version etc? laugh
_________________________
alternaut moderator

Top
#8950 - 03/19/10 08:34 PM Re: eMail hazard [Re: alternaut]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
I suspect he's referring to Apple Mail's annoying habit of making sections of emails get surrounded by a bubble when mousing over them. Makes selecting pieces of text a pain sometimes. I'd like to know how to stop that behavior too. It's similar to how Mail sometimes insists on offering to copy a phone number or something like that as a group when trying to select text.
_________________________
I work for the Department of Redundancy Department

Top
#8967 - 03/20/10 01:41 PM Re: eMail hazard [Re: joyss]
dianne Offline

Moderator

Registered: 08/04/09
joyss,

Might this illustrate the black box you are asking about?

Forwarded Mail in Rich Text Format

If so, go to the Format menu and select Make Plain Text or use Shift - Command - T.
_________________________
dianne • moderator

Back up everything you can't afford to lose – documents, mail, movies, music, photos, and other data and settings.

Top
#8968 - 03/20/10 04:06 PM Re: eMail hazard [Re: alternaut]
joyss Offline


Registered: 09/21/09
I'm not sure what you mean by client. I use the Mac mail system with emails sent to this program by verizon, gmail, and WebMail.

I'm using an iMac and OS 10.6.2
_________________________
(*_*)
iMac
OS 10.6.4

Top
#8969 - 03/20/10 04:10 PM Re: eMail hazard [Re: dianne]
joyss Offline


Registered: 09/21/09
Yes, that is what I see. I'll try your system when I get a new bunch of mail and report. Thamks.
_________________________
(*_*)
iMac
OS 10.6.4

Top
#8970 - 03/20/10 05:06 PM Re: eMail hazard [Re: joyss]
alternaut Offline

Moderator

Registered: 08/04/09
You already answered the main question: your email [server] client is the email program you use on your Mac. tongue
_________________________
alternaut moderator

Top
#8986 - 03/21/10 06:43 PM Re: eMail hazard [Re: alternaut]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
So does anyone know how to disable this "helpful" feature?
_________________________
I work for the Department of Redundancy Department

Top
#8990 - 03/22/10 02:37 AM Re: eMail hazard [Re: Virtual1]
artie505 Online


Registered: 08/04/09
> So does anyone know how to disable this "helpful" feature?

I've run into this annoyance, but I can't duplicate it at the moment; does dianne's post #8967 (Above) answer the question?
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#9000 - 03/22/10 01:28 PM Re: eMail hazard [Re: artie505]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
you can make plain text in a new message, but I don't think when reading one.
_________________________
I work for the Department of Redundancy Department

Top
#9003 - 03/22/10 03:22 PM Re: eMail hazard [Re: Virtual1]
artie505 Online


Registered: 08/04/09
Originally Posted By: Virtual1
you can make plain text in a new message, but I don't think when reading one.

I just tried with a "rich text" message in my inbox:
  • No formatting options reading it.
  • Command-R turns it to "plain text" with an (apparently useless) option to make it rich text.
  • Command-shift-F leaves it as "rich text" with the option to make it "plain text."
I don't think I recall seeing those black boxes other than while returning and/or forwarding; do you see them while reading?
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#9013 - 03/22/10 10:32 PM Re: eMail hazard [Re: Virtual1]
Kevin M. Dean Offline


Registered: 08/04/09
Loc: Florida
Originally Posted By: Virtual1
you can make plain text in a new message, but I don't think when reading one.


Sometimes you sort of can, by switching to the Plain Text alternative if it exists in the email. Command-Option-P or View-->Message-->Plain Text Alternative or Previous/Next Alternative.
_________________________
iMac 2.7 GHz Core i5, 12 GB RAM, OS X 10.9, Int SATA 1 TB, Ext Fire 2 TB / 1 TB / 1 TB / 500 GB / 300 GB
Former MacFixIt Forums member since 11/17/99
www.rhubarbproductions.com

Top
#9064 - 03/27/10 09:53 AM Re: eMail hazard [Re: artie505]
joyss Offline


Registered: 09/21/09
I only see the "black box" upon replying or forwarding. I now change all of these emails to plain text.
_________________________
(*_*)
iMac
OS 10.6.4

Top
#9082 - 03/29/10 02:31 PM Re: eMail hazard [Re: joyss]
joyss Offline


Registered: 09/21/09
CHANGING TO PLAIN TEXT SOLVED THE PROBLEM.
_________________________
(*_*)
iMac
OS 10.6.4

Top
#9198 - 04/04/10 11:39 AM Re: eMail hazard [Re: dianne]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
Thanks for a screenshot. I was wondering what everybody is talking about. I have never seen this behavior in my Mail. Only when Mail sends you an alert (like it did today when I wanted to test a reply after reading this thread) that, e.g., the address of the "reply to" is not recognized. But the original text and my text that I typed on top of it had no such box. My default is, of course, RTF. Could the box be a sign of abnormal behavior rather than a standard feature? What if Mail plist is trashed?
I admit that I only use Mail on an Intel MBP running Snow Leopard.


Edited by macnerd10 (04/04/10 11:40 AM)
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top
#9210 - 04/04/10 05:34 PM Re: eMail hazard [Re: macnerd10]
dianne Offline

Moderator

Registered: 08/04/09
macnerd10

To confirm your settings: Mail > Preferences > Composing > Message Format: Rich Text is selected.
Quote:
But the original text and my text that I typed on top of it had no such box.
  1. Are you replying to a message you have received which was sent in Rich Text?
  2. If you click anywhere in the received Rich Text message which you are replying to, does the black box appear?
Quote:
Could the box be a sign of abnormal behavior rather than a standard feature?
No.
Quote:
What if Mail plist is trashed?
I am not clear if you are offering troubleshooting advice to the original poster . . . who seems to have found an acceptable solution . . . or seeking help in solving a problem you are having.
_________________________
dianne • moderator

Back up everything you can't afford to lose – documents, mail, movies, music, photos, and other data and settings.

Top
#9277 - 04/06/10 10:42 PM Re: eMail hazard [Re: dianne]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
Dianne,
My settings are as you put it. On your 1 - positive. On your 2 - negative. The only thing that is there is the vertical line at the left side of the original message text to which I am replying. But this is understandable because I have "quote the original message" checked. I can edit, remove, type in the text of the original, much like in Entourage. Therefore, I am not as sure as you are that the box is normal. I also don't think that the solution of the OP was great and final; RTF is a nicer format and Apple did not make it a default for nothing, I guess. I would call it a workaround rather than a solution. Is this behavior (with a black box) really that common?
P.S. The box does not appear when forwarding either.


Edited by macnerd10 (04/06/10 10:46 PM)
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top
#9311 - 04/07/10 04:41 PM Re: eMail hazard [Re: macnerd10]
dianne Offline

Moderator

Registered: 08/04/09
Hi, macnerd10
Quote:
I can edit, remove, type in the text of the original, much like in Entourage. Therefore, I am not as sure as you are that the box is normal.
I found these two topics which provide some additional information.

Heavy black eMail text boxes

Box around forwarded mail message

Just some thoughts:
  1. In Mail > Preferences > Composing > Responding: Use the same message format as the original message, is that choice selected or deselected?
  2. Are you sure the message you are replying to or forwarding was sent in Rich Text? (use of different fonts or sizes; use of bold, italic, or underlined text; use of colors)
_________________________
dianne • moderator

Back up everything you can't afford to lose – documents, mail, movies, music, photos, and other data and settings.

Top
#9314 - 04/07/10 07:55 PM Re: eMail hazard [Re: dianne]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
I will get back to you with news from the MBP but I have now tested Mail in 10.5.8 (DP G5 tower). The behavior is exactly as in MBP running 10.6.3.
1. Use the same message format as the original message is selected (composing is Rich Text).
2. In the received message I can see different colors.
I also forwarded one message to myself (the links you provide only deal with forwarded messages) and it behaved exactly as the reply - no boxes, colors were visible, as well as bold text; the links to e-mails behaved as real links.
I noticed that the posters in your links said that "some messages" had boxes. Must be something about these messages.
I got the box in question only once and it did not go around the reply text. It was a message from Mail alerting me that the address of the recipient was not recognized as a valid one. I clicked the X, it went away, the reply text remained in the message and was editable.

P.S. same behavior on 10.6.3. No boxes on reply or forward, with the same settings.


Edited by macnerd10 (04/07/10 11:41 PM)
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top

Moderator:  alternaut, dianne, MacManiac