An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#6579 - 12/10/09 09:41 PM Why is itunes launching?
kevs Offline


Registered: 12/07/09
for some reason F1 in finder, or pressed in any app. is launching itunes.
In System prefs, keyboard, it's not there.
It's not hot keyed in any 3rd party app.
I can't see any reference to in in itunes preferences. I'm baffled. thanks.

Top
#6588 - 12/11/09 05:32 AM Re: Why is itunes launching? [Re: kevs]
Kevin M. Dean Offline


Registered: 08/04/09
Loc: Florida
I don't have 10.6 and I know the way Services are handled has changed a bit, but you may want to check your Services menu as another place where F1 may be assigned to launch iTunes.
_________________________
iMac 2.7 GHz Core i5, 12 GB RAM, OS X 10.9, Int SATA 1 TB, Ext Fire 2 TB / 1 TB / 1 TB / 500 GB / 300 GB
Former MacFixIt Forums member since 11/17/99
www.rhubarbproductions.com

Top
#6590 - 12/11/09 07:53 AM Dock: I lose my icons
kevs Offline


Registered: 12/07/09
With all previous OS, I would drag my hard drives with my icons into the dock and they stuck.
Now I drag them to dock and they are become genereic icons there. anything I can do?
It just worthless having four hardrives in dock -- all with your icon stripped and looking generic. thanks!
They are all now just blue folders except one hard drive which has the hard drive icon, very strange.


Edited by joemikeb (12/11/09 09:03 AM)
Edit Reason: This post merged from post 6579 as the problem and solution are most likely related

Top
#6594 - 12/11/09 08:54 AM Re: Why is itunes launching? [Re: kevs]
joemikeb Online

Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
This may sound too obvious, but do these problems persist after you reboot? If so, have you tried creating a Test account to see if the problems persist in the that account as well? (you can create a test account in System Preferences > Accounts then click on the plus sign (+) at the bottom of the list of accounts.)
_________________________
joemikeb • moderator

Top
#6600 - 12/11/09 10:18 AM Re: Dock: I lose my icons [Re: kevs]
Ira L Online


Registered: 08/13/09
Loc: California
Also maybe too obvious--and not always given the credit it deserves--but try repairing permissions on everything.
_________________________
On a Mac since 1984.
Currently: 27" iMacs, Macbook Air, macOS 10.14.x,; iPhones, iPods and iPads galore!

Top
#6606 - 12/11/09 12:58 PM Re: Dock: I lose my icons [Re: Ira L]
kevs Offline


Registered: 12/07/09
Ok, guys, thanks,
I rebooted, ran disk permission, and logged to a test account.
The dragging hard drives same in test account. It strips the icons and makes icon genric. Is anyone esle on 10.6.2? Do you hardrives retain their custom icons in the dock?
itunes did NOT launch in test user.
I don't see anything in services except the usual link to system prefs.
What's weird is when I do F1, itunes launches, but the window opens quickly and craches, not a normal lauch - and then music starts playing. Would love to know how to get rid of F1 launch. thanks.

Top
#6609 - 12/11/09 03:13 PM Re: Dock: I lose my icons [Re: kevs]
ryck Offline


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: kevs
Is anyone esle on 10.6.2? Do you hardrives retain their custom icons in the dock?


I have 10.6.2 and, although I can't offer any advice to correct your problem, I can advise that mine does not work the way yours does.

I have two external firewire hard drives so I tried what you are doing - drag a hard drive icon to the dock. Neither will not stay there. They just pop back onto the desktop.

So far as the F1 key is concerned....it just operates as a brightness dimmer.

ryck
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS High Sierra 10.13.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 320GB OWC Mercury OTG Pro
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top
#6617 - 12/11/09 07:08 PM Re: Dock: I lose my icons [Re: ryck]
kevs Offline


Registered: 12/07/09
they stay, put them on right side of dock. left for app, right for hard drives and folders.

Top
#6631 - 12/12/09 09:15 AM Re: Dock: I lose my icons [Re: kevs]
ryck Offline


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: kevs
they stay, put them on right side of dock. left for app, right for hard drives and folders.


Tried that and they do stay...as folder icons. The visual difference is that the 'piece of paper?' sticking out the top is a different colour than the piece of paper sticking out of the icons for folders placed there.

A folder placed in the dock has a brown 'piece of paper' sticking out the top. For a drive, it is white .

ryck


Edited by ryck (12/12/09 09:17 AM)
Edit Reason: Clarification
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS High Sierra 10.13.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 320GB OWC Mercury OTG Pro
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top
#6634 - 12/12/09 10:37 AM Re: Dock: I lose my icons [Re: ryck]
kevs Offline


Registered: 12/07/09
This issue was solved on another forum.
Right click choose folder.

Top
#6635 - 12/12/09 11:21 AM Re: Dock: I lose my icons [Re: kevs]
ryck Offline


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: kevs
This issue was solved on another forum.
Right click choose folder.


Great, thanks. I keep my Applications folder in the dock and much prefer the folder icon with the capital A.

ryck
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS High Sierra 10.13.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 320GB OWC Mercury OTG Pro
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top

Moderator:  alternaut, dkmarsh, joemikeb