An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#55311 - 07/21/20 10:23 AM Tabs disappearing
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Lately, when I start my day with my Mac, all the tabs from the previous few days have disappeared off Safari. This happens every few days, not everyday. Firefox still has the tabs I put on there. Any ideas? It's so aggravating. I check the history, but that's a pain as I search a lot. I keep certain tabs open for a reason.

Any help would be appreciated. I can't even log into FTM on Safari anymore. Safari "can't open the webpage." Thank goodness for my Firefox and TOR.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55345 - 07/22/20 01:51 PM Re: Tabs disappearing [Re: plantsower]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Nobody?


Originally Posted By: plantsower
Lately, when I start my day with my Mac, all the tabs from the previous few days have disappeared off Safari. This happens every few days, not everyday. Firefox still has the tabs I put on there. Any ideas? It's so aggravating. I check the history, but that's a pain as I search a lot. I keep certain tabs open for a reason.

Any help would be appreciated. I can't even log into FTM on Safari anymore. Safari "can't open the webpage." Thank goodness for my Firefox and TOR.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55348 - 07/22/20 04:05 PM Re: Tabs disappearing [Re: plantsower]
jchuzi Online


Registered: 08/04/09
Loc: New York State
The best that I can do is to suggest that you empty the Safari cache. If you don't have the Develop menu enabled (Safari > Preferences > Advanced), you can use the keyboard shortcut: Command-Option-E.

Relaunch Safari and see if that helps. This is a stab in the dark, but it won't hurt anything. Be aware, however, that you will temporarily lose site-specific icons. They will regenerate as you navigate to those sites.


Edited by jchuzi (07/22/20 04:40 PM)
_________________________
Jon

macOS 10.15.6, iMac Retina 5K 27-inch, late 2014, 3.5 GHz Intel Core i5, 1 TB fusion drive, 16 GB RAM, Epson SureColor P600, Photoshop CC, Lightroom CC, MS Office 365

Top
#55350 - 07/22/20 04:52 PM Re: Tabs disappearing [Re: jchuzi]
joemikeb Online
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
The can't open web page notification taken together with the loss of your tab settings sounds like something an internet security app might do. Are you running any new internet protection software, or perhaps one you have been using for a while has been updated with new features? What, if any, Safari extensions are you running?
_________________________
joemikeb • moderator

Top
#55360 - 07/23/20 09:29 AM Re: Tabs disappearing [Re: jchuzi]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Hi Jon:

I do have the develop icon on my toolbar. I just don't think to empty cache when something goes wrong. I will do that and restart the next time it happens.. Thanks.



Originally Posted By: jchuzi
The best that I can do is to suggest that you empty the Safari cache. If you don't have the Develop menu enabled (Safari > Preferences > Advanced), you can use the keyboard shortcut: Command-Option-E.

Relaunch Safari and see if that helps. This is a stab in the dark, but it won't hurt anything. Be aware, however, that you will temporarily lose site-specific icons. They will regenerate as you navigate to those sites.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55361 - 07/23/20 09:36 AM Re: Tabs disappearing [Re: joemikeb]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
No new security software, but I do have a lot of extensions:
Ad Block Engine
Adblock icon, ABP
ABP control panel
AB block utilities
Ad blocker for Youtube (doesn't seem to work on Safari)
Ebates Rakuten cash back
Ghostery
Honey
Wipr

Looks like I've overdone it. Any ideas about which to get rid of and still get what I need would be welcome. Thanks. I think, if I remember correctly, Wipr caused me problems in the past.



Originally Posted By: joemikeb
The can't open web page notification taken together with the loss of your tab settings sounds like something an internet security app might do. Are you running any new internet protection software, or perhaps one you have been using for a while has been updated with new features? What, if any, Safari extensions are you running?
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55370 - 07/23/20 01:37 PM Re: Tabs disappearing [Re: plantsower]
joemikeb Online
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
I don't see any obvious suspects among your extensions, but any ad blocker could be the source of
Quote:
can't open the webpage
. The ADBlock and WIPR (I presume that is WIPR Part 1, WIPR Part 2, & WIPR Part 3) extensions duplicate one another functionally, so you might try deactivating one or the other, you don't have to delete them, and see if that error re-occurs. But neither of those should effect your tab settings.

Tab settings are stored in a preference file somewhere in your user Library which leads me to suspect some app outside of Safari as the culprit, but at the moment, I have no clue what it would be. confused
_________________________
joemikeb • moderator

Top
#55372 - 07/23/20 01:57 PM Re: Tabs disappearing [Re: joemikeb]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
I didn't know there was a WIPR 1, 2 and 3. I just have one of them. That's scary and frustrating that it could be one of my apps, and there is no way to tell. In doing a Google search just now, I guess I'm not the only one, though I didn't find a solution.


Originally Posted By: joemikeb
I don't see any obvious suspects among your extensions, but any ad blocker could be the source of
Quote:
can't open the webpage
. The ADBlock and WIPR (I presume that is WIPR Part 1, WIPR Part 2, & WIPR Part 3) extensions duplicate one another functionally, so you might try deactivating one or the other, you don't have to delete them, and see if that error re-occurs. But neither of those should effect your tab settings.

Tab settings are stored in a preference file somewhere in your user Library which leads me to suspect some app outside of Safari as the culprit, but at the moment, I have no clue what it would be. confused
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55374 - 07/23/20 02:26 PM Re: Tabs disappearing [Re: plantsower]
artie505 Online


Registered: 08/04/09
Originally Posted By: plantsower
I didn't know there was a WIPR 1, 2 and 3. I just have one of them.

After installing Wipr you should see this.

I"m not certain what all three parts do, but the developer advised me that it works best with all three enabled.

Maybe you ought to reinstall it.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#55375 - 07/23/20 02:30 PM Re: Tabs disappearing [Re: plantsower]
artie505 Online


Registered: 08/04/09
Originally Posted By: plantsower
I can't even log into FTM on Safari anymore. Safari "can't open the webpage."

Is that where it ends? Nothing more specific than that?

Just to cover all bases, try disabling ALL your Safari extensions at once and see what, if anything, happens, and play it by ear from there.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#55376 - 07/23/20 05:49 PM Re: Tabs disappearing [Re: plantsower]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: plantsower
I can't even log into FTM on Safari anymore. Safari "can't open the webpage." Thank goodness for my Firefox and TOR.
Interesting, I just ran into the same issue. Somehow I was logged out earlier today and—like you—could not log in anymore to comment here (Safari Can't Open the Page). No problem on Chrome. After a reboot my first attempt to log in on Safari had the same problem, but the second succeeded, albeit with a fraction of the Forum List page showing. A refresh restored the rest.*

As it happens, my internal hard drive is about to die (due to ‘a significant number of damaged areas’), and I couldn’t be sure if the two phenomena were related or interacting. Anyway, I would suggest you (1) reboot and see if you can login again (it might also clear Safari’s ‘cobwebby’ tabs…), and (2) run a hardware test on your HD, just in case.

*) Curious. It turns out I could not post this on Safari after using Preview, which in turn only showed after hitting that button twice, with a subsequent Submit resulting in an error (Safari Can't Open the Page). Bypassing Preview to Submit worked. Adding this addendum showed the same strange behavior: previewing before submitting required two button hits, whereupon Submit returned the error. Returning to the edit page via the back arrow and then hitting Submit worked. Weird, and I’m now pretty sure it isn’t my HD.


Edited by alternaut (07/23/20 06:11 PM)
_________________________
alternaut moderator

Top
#55381 - 07/24/20 09:52 AM Re: Tabs disappearing [Re: plantsower]
joemikeb Online
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
Originally Posted By: plantsower
I didn't know there was a WIPR 1, 2 and 3. I just have one of them. That's scary and frustrating that it could be one of my apps, and there is no way to tell. In doing a Google search just now, I guess I'm not the only one, though I didn't find a solution.

🤦🏻‍♂️ I just remembered you running Sierra (MacOS 10.12). I forget whether it was in High Sierra or Mojave, Apple dropped support for the style of extensions used in previous MacOS and Safari versions and switched to extensions downloaded from the App Store. That is when WIPR 1, WIPR 2, and WIPR 3 came on the scene. As to AdBlock, as far as I know AdBlock Pro - Legacy ($9.99) is the only supported version of AdBlock for legacy systems such as Sierra. While your legacy ad blockers may continue to work, they will become less and less effective as advertisers develop newer ways of avoiding blockers. I suggest you consider Uninstalling all of your current ad blockers and install AdBlock Pro - Legacy.

Unfortunately, while that will most likely improve your ad blocking, it does not solve either the issue of being unable to reach FineTunedMac using Safari or Safari's disappearing tabs. While I can think of any number of reasons, you might be getting that error message, all of them would affect any browser on your system, not just Safari. The one thing I can think of would be an intermittent network situation that coincidentally occurred while you were using Safari. (Yes, I know that is thin and still leaves the disappearing tabs completely unexplained, but it is all I've got at the moment 🤓.)
_________________________
joemikeb • moderator

Top
#55382 - 07/24/20 09:57 AM Re: Tabs disappearing [Re: alternaut]
joemikeb Online
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
Originally Posted By: alternaut
*) Curious. It turns out I could not post this on Safari after using Preview, which in turn only showed after hitting that button twice, with a subsequent Submit resulting in an error (Safari Can't Open the Page). Bypassing Preview to Submit worked. Adding this addendum showed the same strange behavior: previewing before submitting required two button hits, whereupon Submit returned the error. Returning to the edit page via the back arrow and then hitting Submit worked. Weird, and I’m now pretty sure it isn’t my HD.

Do you mean the Preview App in MacOS or the UBB Preview Post in Safari?
_________________________
joemikeb • moderator

Top
#55383 - 07/24/20 09:58 AM Re: Tabs disappearing [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Yep, from what I can remember. See Alternaut's subsequent post.

Originally Posted By: artie505
Originally Posted By: plantsower
I can't even log into FTM on Safari anymore. Safari "can't open the webpage."

Is that where it ends? Nothing more specific than that?

Just to cover all bases, try disabling ALL your Safari extensions at once and see what, if anything, happens, and play it by ear from there.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55384 - 07/24/20 10:01 AM Re: Tabs disappearing [Re: alternaut]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Safari and FTM are playing nice now. It only happens now and then, but when I go to Develop and "open page with Firefox", all is well. I do refresh my browser now and then.

Originally Posted By: alternaut
Originally Posted By: plantsower
I can't even log into FTM on Safari anymore. Safari "can't open the webpage." Thank goodness for my Firefox and TOR.
Interesting, I just ran into the same issue. Somehow I was logged out earlier today and—like you—could not log in anymore to comment here (Safari Can't Open the Page). No problem on Chrome. After a reboot my first attempt to log in on Safari had the same problem, but the second succeeded, albeit with a fraction of the Forum List page showing. A refresh restored the rest.*

As it happens, my internal hard drive is about to die (due to ‘a significant number of damaged areas’), and I couldn’t be sure if the two phenomena were related or interacting. Anyway, I would suggest you (1) reboot and see if you can login again (it might also clear Safari’s ‘cobwebby’ tabs…), and (2) run a hardware test on your HD, just in case.

*) Curious. It turns out I could not post this on Safari after using Preview, which in turn only showed after hitting that button twice, with a subsequent Submit resulting in an error (Safari Can't Open the Page). Bypassing Preview to Submit worked. Adding this addendum showed the same strange behavior: previewing before submitting required two button hits, whereupon Submit returned the error. Returning to the edit page via the back arrow and then hitting Submit worked. Weird, and I’m now pretty sure it isn’t my HD.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55385 - 07/24/20 10:03 AM Re: Tabs disappearing [Re: joemikeb]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Yep, I know about the extension/app thing from our previous conversations. If things continue to go wonky, it just might be the push I need to upgrade way up to High Sierra! LOL!


Originally Posted By: joemikeb
Originally Posted By: plantsower
I didn't know there was a WIPR 1, 2 and 3. I just have one of them. That's scary and frustrating that it could be one of my apps, and there is no way to tell. In doing a Google search just now, I guess I'm not the only one, though I didn't find a solution.

🤦🏻‍♂️ I just remembered you running Sierra (MacOS 10.12). I forget whether it was in High Sierra or Mojave, Apple dropped support for the style of extensions used in previous MacOS and Safari versions and switched to extensions downloaded from the App Store. That is when WIPR 1, WIPR 2, and WIPR 3 came on the scene. As to AdBlock, as far as I know AdBlock Pro - Legacy ($9.99) is the only supported version of AdBlock for legacy systems such as Sierra. While your legacy ad blockers may continue to work, they will become less and less effective as advertisers develop newer ways of avoiding blockers. I suggest you consider Uninstalling all of your current ad blockers and install AdBlock Pro - Legacy.

Unfortunately, while that will most likely improve your ad blocking, it does not solve either the issue of being unable to reach FineTunedMac using Safari or Safari's disappearing tabs. While I can think of any number of reasons, you might be getting that error message, all of them would affect any browser on your system, not just Safari. The one thing I can think of would be an intermittent network situation that coincidentally occurred while you were using Safari. (Yes, I know that is thin and still leaves the disappearing tabs completely unexplained, but it is all I've got at the moment 🤓.)
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55386 - 07/24/20 10:04 AM Re: Tabs disappearing [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Something to think about.


Originally Posted By: artie505
Originally Posted By: plantsower
I didn't know there was a WIPR 1, 2 and 3. I just have one of them.

After installing Wipr you should see this.

I"m not certain what all three parts do, but the developer advised me that it works best with all three enabled.

Maybe you ought to reinstall it.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 12.1.2




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#55391 - 07/24/20 11:52 AM Re: Tabs disappearing [Re: plantsower]
artie505 Online


Registered: 08/04/09
Originally Posted By: plantsower
Something to think about.


Originally Posted By: artie505
Originally Posted By: plantsower
I didn't know there was a WIPR 1, 2 and 3. I just have one of them.

After installing Wipr you should see this.

I"m not certain what all three parts do, but the developer advised me that it works best with all three enabled.

Maybe you ought to reinstall it.

Yep, but totally qualified by joemike's post. (I forgot about your legacy OS.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top

Moderator:  alternaut, dianne, MacManiac