An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#45208 - 06/16/17 04:03 PM Stopping autoplay on videos
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
I have always used ClicktoFlash and Clicktoplugin but these are not working on Sierra. Maybe they are HTML videos, I don't know, but it's annoying. I read where there was a terminal command to get rid of this, which I did, but it's not working either.

Terminal showed the Debug menu for me. Then I'm supposed to click media flags (which I can't find) and then "disallow inline video" or "Video needs user action."
I did the latter but it didn't work and now I can't even find media flags under the debug section.

Any ideas? Something simples, step by step.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45210 - 06/16/17 04:29 PM Re: Stopping autoplay on videos [Re: plantsower]
artie505 Online


Registered: 08/04/09
I'm not exactly sure what your problem is, but I posted a while back that I had to uninstall ClickToPlugin to get videos playing. (ClickTo Flash probably also needs to be uninstalled.)

Before you uninstall, try unchecking, i.e. disabling, them to see what happens.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#45213 - 06/16/17 05:51 PM Re: Stopping autoplay on videos [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Maybe I wasn't clear. Clicktoplugin and Clicktoflash work perfectly on my old MBP. But now with Sierra they don't. I only installed them on my new MBP because I was going to websites that were playing videos without my permission like in the past before I installed those apps. So, I thought they might help but they don't.

Originally Posted By: artie505
I'm not exactly sure what your problem is, but I posted a while back that I had to uninstall ClickToPlugin to get videos playing. (ClickTo Flash probably also needs to be uninstalled.)

Before you uninstall, try unchecking, i.e. disabling, them to see what happens.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45214 - 06/16/17 06:12 PM Re: Stopping autoplay on videos [Re: plantsower]
artie505 Online


Registered: 08/04/09
Or maybe I"m a little dense. tongue

The videos that are playing without permission are HTML5; in the Sierra version of Safari you get an "Allow?" pop-up when you hit a Flash video. The controlling pref is Safari > Prefs > Security > Internet plug-ins, where I've got "Allow..." and Plug-in Settings > Adobe Flash Player (and SharePoint Browser Plug-in) checked, which results in that pop-up popping up.

I uninstalled ClickToFlash long ago, because its functionality was duplicated in ClickTo Plugin, but CTP's functionality has become unnecessary in the Sierra version of Safari, and I've now uninstalled it, too.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#45215 - 06/16/17 08:18 PM Re: Stopping autoplay on videos [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Uh-oh, sorry Artie, I read your message too fast! Now I see what you are saying about them being HTMLs. Hurray! Not sure why I am getting that error message though.
Also, I saw this in Apple Discussions which verifies what you said.
Note: The new default behaviour for Safari is not to enable flash on web sites. You have to explicitly enable it per website in Safari Preferences. Since most of YouTube content is available in HTML5 you do not need to enable Flash for YouTube, you would need to enable Flash for BBC iPlayer though as one example.I already have Allow..... checked. The videos that played already are ads or something. I didn't even see them. I could hear them as I was on another website.

I just went to YouTube and found out I cannot play any videos. I get the message: Your browser does not currently recognize any of the video formats available.. I used to get that on my old MBP but I thought it was because I hadn't upgraded my OS. But I could still play flash which I choose not to do and HTML. Now I have no choice. Whatever video I click on starts with the loading circle in the middle of the screen. It doesn't stop no matter if I put it on pause or play and it never loads up. I may have to call Apple tomorrow. But, hey, I have AppleCare!


Originally Posted By: artie505
Or maybe I"m a little dense. tongue

The videos that are playing without permission are HTML5; in the Sierra version of Safari you get an "Allow?" pop-up when you hit a Flash video. The controlling pref is Safari > Prefs > Security > Internet plug-ins, where I've got "Allow..." and Plug-in Settings > Adobe Flash Player (and SharePoint Browser Plug-in) checked, which results in that pop-up popping up.

I uninstalled ClickToFlash long ago, because its functionality was duplicated in ClickTo Plugin, but CTP's functionality has become unnecessary in the Sierra version of Safari, and I've now uninstalled it, too.


Edited by plantsower (06/16/17 08:57 PM)
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45216 - 06/16/17 08:24 PM Re: Stopping autoplay on videos [Re: plantsower]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
OK, I just tried something. I disabled clicktoflash and clicktoplugin and now I can get Youtube Videos but I don't know whether they are playing in flash or HTML. Since I heard flash allows people to hack your computer, I prefer HTML. How do I tell which is playing and if it is flash, how can I change it to the HTML format like I used to do?
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45217 - 06/17/17 02:29 AM Re: Stopping autoplay on videos [Re: plantsower]
artie505 Online


Registered: 08/04/09
Originally Posted By: Rita
The videos that played already are ads or something. I didn't even see them. I could hear them as I was on another website.

Not sure why I am getting that error message though.

I'm not sure if it's universal or selective, but at least some videos put a little volume control at the right end of my address field (next to the reload arrow), and clicking on it turns the sound off.

More: The error message is somehow prompted by the "ClickTo-s"; I got the same message until I uninstalled ClickTo Plugin.


Edited by artie505 (06/17/17 02:58 AM)
Edit Reason: More
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#45219 - 06/17/17 08:26 AM Re: Stopping autoplay on videos [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
You're right. After I got rid of the plugins that message stopped. Thanks.

Originally Posted By: artie505
Originally Posted By: Rita
The videos that played already are ads or something. I didn't even see them. I could hear them as I was on another website.

Not sure why I am getting that error message though.

I'm not sure if it's universal or selective, but at least some videos put a little volume control at the right end of my address field (next to the reload arrow), and clicking on it turns the sound off.

More: The error message is somehow prompted by the "ClickTo-s"; I got the same message until I uninstalled ClickTo Plugin.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45222 - 06/17/17 08:56 AM Re: Stopping autoplay on videos [Re: plantsower]
joemikeb Offline
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
Safari > Preferences > Websites > Auto-Play then you can allow or disallow automatic media play on a website-by-website basis.
_________________________
joemikeb • moderator

Top
#45225 - 06/17/17 09:18 AM Re: Stopping autoplay on videos [Re: joemikeb]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
I went to Safari - Prefs but there is no "website" word. Maybe you skipped a step?

Originally Posted By: joemikeb
Safari > Preferences > Websites > Auto-Play then you can allow or disallow automatic media play on a website-by-website basis.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45226 - 06/17/17 09:19 AM Re: Stopping autoplay on videos [Re: joemikeb]
artie505 Online


Registered: 08/04/09
Originally Posted By: joemikeb
Safari > Preferences > Websites > Auto-Play then you can allow or disallow automatic media play on a website-by-website basis.

That pref doesn't exist in the current version of Safari, i.e. 10.1.1; I guess it's a beta or technology preview thing? (See my post #45214.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#45230 - 06/17/17 10:27 AM Re: Stopping autoplay on videos [Re: artie505]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Thanks. I thought I was losing it. smile


Originally Posted By: artie505
Originally Posted By: joemikeb
Safari > Preferences > Websites > Auto-Play then you can allow or disallow automatic media play on a website-by-website basis.

That pref doesn't exist in the current version of Safari, i.e. 10.1.1; I guess it's a beta or technology preview thing? (See my post #45214.)
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45231 - 06/17/17 10:45 AM Re: Stopping autoplay on videos [Re: artie505]
joemikeb Offline
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
Oops! blush
That, along with a lot of other site by site options is in the Safari Technology Preview Release 33 (Safari 11.0, WebKit 12604.1.25.0.2) and the version of Safari that will ship with High Sierra. Consider my comment a preview of coming attractions.
_________________________
joemikeb • moderator

Top
#45232 - 06/17/17 10:58 AM Re: Stopping autoplay on videos [Re: joemikeb]
plantsower Offline


Registered: 09/13/09
Loc: Burson, CA
Will do..

Originally Posted By: joemikeb
Oops! blush
That, along with a lot of other site by site options is in the Safari Technology Preview Release 33 (Safari 11.0, WebKit 12604.1.25.0.2) and the version of Safari that will ship with High Sierra. Consider my comment a preview of coming attractions.
_________________________
MacBook Pro - Sierra 10.12.6, Safari 11.1




iPhone 5s Version 9.3.2 iTunes 12.4.0.119

Top
#45237 - 06/17/17 01:36 PM Re: Stopping autoplay on videos [Re: joemikeb]
artie505 Online


Registered: 08/04/09
Originally Posted By: joemikeb
Consider my comment a preview of coming attractions.

I did, and I like what's coming...in this instance, anyhow. tongue
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top

Moderator:  alternaut, dianne, MacManiac