An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#41913 - 09/23/16 11:57 PM Can't run 10.11.6 Combo
artie505 Online


Registered: 08/04/09
I decided to run the 10.11.6 Combo (I updated with the Delta.) in connection with a Safari 10 issue, because it includes a version of Safari 9, and I was hoping to revert (as happened with the 10.6.8 Combo and, I assume, Delta), but OS X refuses to allow it run: "This volume does not meet the requirements for this update."

Has a venerable troubleshooting technique bitten the dust, can OS X be fooled into allowing it to run, or, on the other hand, is it a local issue on my Mac?

Thanks.

Edit: Just d/l'ed the Delta, and it won't run either.


Edited by artie505 (09/24/16 02:14 AM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#41915 - 09/24/16 03:06 AM Re: Can't run 10.11.6 Combo [Re: artie505]
jchuzi Online


Registered: 08/04/09
Loc: New York State
Can you revert from a Time Machine backup?
_________________________
Jon

OS 10.14.4, iMac Retina 5K 27-inch, late 2014, 3.5 GHz Intel Core i5, 1 TB fusion drive, 16 GB RAM, Epson SureColor P600, Photoshop CC, Lightroom CC, MS Office 365

Top
#41916 - 09/24/16 03:17 AM Re: Can't run 10.11.6 Combo [Re: jchuzi]
artie505 Online


Registered: 08/04/09
I don't use Time Machine, Jon.

I guess I'm either stuck with the issue...not a catastrophe, or I'll have to do a clean install of El Cap. (I wonder if Safari 10 will behave differently in Sierra than it does in El Cap? Maybe I'll install it on a clone.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#41959 - 09/26/16 01:58 AM Re: Can't run 10.11.6 Combo [Re: artie505]
artie505 Online


Registered: 08/04/09
Isn't there a file somewhere that identifies the version of OS X a Mac is running and can be modified to fool the overlords?
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#42015 - 09/30/16 09:58 AM Re: Can't run 10.11.6 Combo [Re: artie505]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
Originally Posted By: artie505
"This volume does not meet the requirements for this update."

That's got to be one of the most irritating error messages I've ever seen from Apple. "We saw something we don't like, so we're going to refuse to run, and not give you the option to try anyway. We also won't be giving you a grain of useful information, and won't write anything helpful in any of the log files either. Good luck figuring out why we're unhappy!"

I ran into that error numerous times trying to upgrade os x for users. Either running incremental or combo updaters, OR trying to (re)install OS X. I suspect it's something in the preflight or in the base installer, but was never able to identify it specifically. In almost every case I was forced to "hide" the OS (or delete it) and THEN run the base OS installer and updater, and finally reimport the user data.
_________________________
I work for the Department of Redundancy Department

Top
#42043 - 10/03/16 05:01 PM Re: Can't run 10.11.6 Combo [Re: Virtual1]
artie505 Online


Registered: 08/04/09
Originally Posted By: Virtual1
...I was forced to "hide" the OS (or delete it)....

That almost answers my

Quote:
Isn't there a file somewhere that identifies the version of OS X a Mac is running and can be modified to fool the overlords?

I remember there being a file somewhere in either /System/Library or /Library that can be deleted or modified to fool the installer, but I don't remember where it is.

(As an afterthought, I tried to run the Combo in safe mode with the same lack of success I experienced in regular mode.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#42100 - 10/08/16 02:29 PM Re: Can't run 10.11.6 Combo [Re: Virtual1]
artie505 Online


Registered: 08/04/09
It just occurred to me that the reason the 10.11.6 Combo won't run may be precisely why I wanted to run it...to revert from Safari 10 to Safari 9. Allowing the 10.6.8 Combo to re-run and revert Safari from App Store compatible 5.10 (was it?) to a non-compatible version must have caused Apple a passel of problems.

(And the dumb thing is that I just did a clean install, forgot to leave well enough alone at v 9, and updated to v 10. frown )
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#42261 - 10/24/16 08:18 AM Re: Can't run 10.11.6 Combo [Re: artie505]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
Originally Posted By: artie505
Isn't there a file somewhere that identifies the version of OS X a Mac is running and can be modified to fool the overlords?

Yeah, that was my first lead. And is very likely correct. But the catch is, that information is stored in multiple places. Apple never was very consistent with that.

/System/Library/CoreServices/SystemVersion.plist

I have that one memorized and use it ALL THE TIME. It's probably the only officially supported plist file that Apple continues to maintain in text (not BPPL binary format) because everybody and their dog know to look in that text file to see what version of OS is running. AFAIK that's been there since 10.0. Editing that won't, for example, change the version number reported in About This Macintosh or in System Profiler, indicating the version is being drawn from another source. (bad practice IMHO)

cat /System/Library/CoreServices/SystemVersion.plist | grep -A1 ProductUserVisibleVersion | grep string | cut -d '>' -f 2 | cut -d '<' -f 1

it's a bit long and unsightly, but many many many scripts and apps use some variation on that to get the version of Mac OS X running.

And no, fixing that almost never fixes the aforementioned error message. I've seen it work ONCE, when that file was outright MISSING on a hard drive.
_________________________
I work for the Department of Redundancy Department

Top
#42281 - 10/24/16 05:38 PM Re: Can't run 10.11.6 Combo [Re: Virtual1]
artie505 Online


Registered: 08/04/09
Originally Posted By: Virtual1
System/Library/CoreServices/SystemVersion.plist

....

...fixing that almost never fixes the aforementioned error message. I've seen it work ONCE, when that file was outright MISSING on a hard drive.

As you said, editing that file didn't resolve my error message problem (even after shutting down/starting up).
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top

Moderator:  alternaut, dkmarsh, joemikeb