An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#2876 - 09/03/09 11:04 PM Epson printer problems
tunalue Offline


Registered: 09/03/09
I screwed up the Epson Stylus Color 740 so that now it only flashes it's lights and doesn't print. It was working happily with Windoze XP and when tried to change the cartridge I lost patience, thwarted the cartridge/carriage(?) return. I've tried ignoring it. I've unplugged it for days. I've tried - unsuccessful;y - to run head cleaning and the other utilities. I've removed the cartridges and replaced them with new ones. Nada/Zip/Zilch results.

Also have an Epson Stylus Color 740i that I can't get to print with the G4 MDD running 10.4.11 but I haven't tried the 740i with the Gateway PC & XP

I have a large # of cartridges that work for both of them and, like many others, am not rolling in bucks so I really want at least one of these suckers to work again. It'd be ideal if each of them would play nicely so that I had a working printer on each trailing edge computer...

I realize this isn't enough info but am not quite sure where to start providing what kind of info is needed.

TIA,

Tunalue

Top
#2884 - 09/04/09 03:28 AM Re: Epson printer problems [Re: tunalue]
freelance Offline


Registered: 08/05/09
Loc: London, UK
I'm sorry I can't be of more help, but:

We had a similar problem with an Epson printer at work. We had to unplug the printer, reconnnect it and press a very specific sequence of buttons, which may vary from printer to printer. If you go to the troubleshooting pages of Epson's website, you will find the instructions you need. Or chat online with an advisor.

Hopefully.
_________________________
Mac Pro dual-2.4 GHz, 10.13.6, 24 Gb RAM, 250 Gb Samsung EVO SSD/Velocity Solo PCIe card, 2x3Tb Seagate HD, 1x3Tb Hitachi HD, Dell 2408WFP; Canon PIXMA iX6550; CanoScan 8800F; MacBook Air 1.8 Ghz, 8 Gb RAM, 10.14.1, 256 Gb SSD; BT Home Hub 6/Wi-Fi Extender.

Top
#2926 - 09/04/09 04:49 PM Re: Epson printer problems [Re: freelance]
tunalue Offline


Registered: 09/03/09
Originally Posted By: freelance


If you go to the troubleshooting pages of Epson's website, you will find the instructions you need. Or chat online with an advisor.

Hopefully.


Thanks for the moral support AND the suggestion to check the Epson website (duh!). Didn't even know of the online advisor!!

Top
#2943 - 09/05/09 01:32 AM Re: Epson printer problems [Re: tunalue]
freelance Offline


Registered: 08/05/09
Loc: London, UK
Quote:
Didn't even know of the online advisor!!

I had an occasion to use the online advisor to sort out the driver installation for an R1800. The service was pretty quick and sorted the problem for me. Good luck!
_________________________
Mac Pro dual-2.4 GHz, 10.13.6, 24 Gb RAM, 250 Gb Samsung EVO SSD/Velocity Solo PCIe card, 2x3Tb Seagate HD, 1x3Tb Hitachi HD, Dell 2408WFP; Canon PIXMA iX6550; CanoScan 8800F; MacBook Air 1.8 Ghz, 8 Gb RAM, 10.14.1, 256 Gb SSD; BT Home Hub 6/Wi-Fi Extender.

Top
#3007 - 09/05/09 03:22 PM Re: Epson printer problems [Re: tunalue]
MicroMatTech3 Offline


Registered: 08/04/09
_________________________
MicroMat Inc
Makers of TechTool

Top
#3380 - 09/09/09 06:05 AM Re: Epson printer problems [Re: tunalue]
Gregg Offline


Registered: 08/04/09
Loc: Milwaukee, WI (USA)
Any luck? I have the same printer. I'd be interested to know how your situation turns out.

Top
#3400 - 09/09/09 10:06 AM Re: Epson printer problems [Re: Gregg]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
Did you ever try Gutenprint drivers?
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top
#3424 - 09/09/09 02:50 PM Re: Epson printer problems [Re: macnerd10]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
I've had bad luck with guttenprint drivers almost every time I've tried them. What's the World's opinion?
_________________________
I work for the Department of Redundancy Department

Top
#3438 - 09/09/09 07:07 PM Re: Epson printer problems [Re: Virtual1]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
I had bad luck trying to start an HP LJ 1200 in SL. It immediately started to work once I chose the Gutenprint driver. I guess, Jon also likes them. That was my first experience because I could not make it work with an HP driver.
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top
#3439 - 09/09/09 07:11 PM Re: Epson printer problems [Re: Virtual1]
joemikeb Offline
Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
I have always had good results with the Gutenprint drivers, especially with Epson printers but I am confident you have tried a much wider variety than I have. FWIW I always download the latest set of their drivers before installing a new one. The Gutenprint drivers that ship with OS X are generally from an older release.
_________________________
joemikeb • moderator

Top

Moderator:  alternaut, cyn