An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#34045 - 04/29/15 04:31 AM Apple Mail not displaying properly
ryck Online


Registered: 08/04/09
Loc: Okanagan Valley
Recently I did conducted one of my rare drive defragmentations. I used TechTool Pro. Since then, Apple Mail on my iMac displays images as a blank space with a small blue question mark in the centre.

I've looked around and the most common response seems to be ensuring that "Display remote images in HTML messages" is ticked under mail preferences. It is. Also, I conclude that the issue is with my Mail application, not a remote site, as the images display correctly on my iPad.

Cocktail has a function under System>Databases called "Rebuild Mail's Envelope Index". Does this sound like a reasonable next step, or is there something else to do first?

Are there any cautions to be noted with rebuilding the index?
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS Mojave 10.14.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 1TB LaCie USB-C
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top
#34052 - 04/29/15 10:40 AM Re: Apple Mail not displaying properly [Re: ryck]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
make sure you have "display remote images in HTML messages" checked in mail's preferences, under Viewing. (it's checked by default)

(some people turn that off to prevent web bug tracking)
_________________________
I work for the Department of Redundancy Department

Top
#34058 - 04/29/15 04:54 PM Re: Apple Mail not displaying properly [Re: ryck]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Rebuilding the index is harmless.

Mail will normally download the images in messages and then store them in a cache. If you do some sort of system optimization that flushes downloaded Mail attachments, that might explain what you're seeing. Simply defragmenting the disk should not do that, however.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#34071 - 04/30/15 09:55 AM Re: Apple Mail not displaying properly [Re: Virtual1]
ryck Online


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: Virtual1
make sure you have "display remote images in HTML messages" checked in mail's preferences

Doneā€¦.no change.
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS Mojave 10.14.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 1TB LaCie USB-C
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top
#34072 - 04/30/15 10:02 AM Re: Apple Mail not displaying properly [Re: tacit]
ryck Online


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: tacit
Mail will normally download the images in messages and then store them in a cache. If you do some sort of system optimization that flushes downloaded Mail attachments, that might explain what you're seeing.

I am noticing that the issue isn't with all email images. Some are arriving with their images intact and others without. I note that those arriving without still don't display even when using the "View this email on-line" or "View this email in your browser" option.

I may just keep an eye on things. If it's restricted to a few senders, it's not something to lose sleep over.


Edited by ryck (04/30/15 10:03 AM)
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS Mojave 10.14.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 1TB LaCie USB-C
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top
#34145 - 05/06/15 09:25 AM Re: Apple Mail not displaying properly [Re: ryck]
MG2009 Offline


Registered: 08/05/09
"If it's restricted to a few senders, it's not something to lose sleep over."


I have that same issue myself . . . BUT with only one person who sends e-mails to me from a Windows computer AND with only some of the e-mails he sends.

So . . . it MAY well be an issue from the Sender's end (???).
_________________________
Many thanks,
MG2009

Top
#34148 - 05/06/15 09:38 AM Re: Apple Mail not displaying properly [Re: MG2009]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
they may be using an outdated (i.e. VERY old) version of some mail application, like some ancient MS Outlook, which is using nonstandard or depreciated MIME formatting. Tell them to check for updates wink
_________________________
I work for the Department of Redundancy Department

Top
#34150 - 05/06/15 04:41 PM Re: Apple Mail not displaying properly [Re: MG2009]
ryck Online


Registered: 08/04/09
Loc: Okanagan Valley
Originally Posted By: MG2009
So . . . it MAY well be an issue from the Sender's end (???).

No, it's a few senders and they aren't always individuals. Sometimes the mail is from companies. I find that sometimes these things just seem to fix themselves, so I'm just as happy to wait it out.


Edited by ryck (05/06/15 04:44 PM)
_________________________
ryck

iMac (Retina 5K, 27", 2017), 3.4 GHz Intel Core i5, 8GB RAM, 2400 MHz DDR4
OS Mojave 10.14.6
Canon MX710 Printer
Epson Perfection V500 Photo Scanner
Time Machine on 1TB LaCie USB-C
Carbon Copy Clone on 500GB OWC Mercury OTG Pro

Top

Moderator:  alternaut, dianne, MacManiac