An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#20341 - 01/26/12 01:20 PM Firefox upgrades: crazy
Bensheim Offline


Registered: 08/16/09
Loc: UK
With the office closed for a week, I thought I'd go around all the Macs and get around to downloading the Firefox upgrades which constantly nag us. <---please note, they nag us to upgrade all the time but we're too busy until a moment like this.

First Mac, went to Firefox, it said "HEY! you seem to be running an out of date version. Wanna upgrade?" I followed the usual procedure, but when I came to instal it in the Applications folder the Mac said "You seem to be installing an older version over the one which already exists. Are you sure you want to do this?"

I read it twice. Older over the one which already exists......... no.

Go to second Mac. Repeat procedure. Exact same thing happened.

Go to third Mac. Repeat procedure. Exact same thing happened.

Have not tried 4th Mac yet, there seems no point.

So why the Heck, on these Macs, does Firefox continually say "Hey, you seem to be........

Firefox, make your bleeping mind up. Do we need an upgrade or NOT? (3.6.25 here, on Snow Leopard)

confused

Top
#20343 - 01/26/12 01:35 PM Re: Firefox upgrades: crazy [Re: Bensheim]
artie505 Online


Registered: 08/04/09
I'm running Firefox 8.0, and there's a 9.x beta out there, so something sounds wacky, like have you maybe got two different versions of Firefox in two different locations? (What does a command-I on Firefox in your apps folder tell you?)
_________________________
The new Great Equalizer is the SEND button.

Top
#20345 - 01/26/12 02:03 PM Re: Firefox upgrades: crazy [Re: Bensheim]
dkmarsh Offline
Moderator

Registered: 08/04/09

You might try clicking and holding on the running Firefox's Dock icon, then choosing Show in Finder from the contextual menu...just to be sure that the Firefox you're running is indeed located in /Applications.
_________________________

dkmarsh • member, FineTunedMac Co-op Board of Directors

Top
#20346 - 01/26/12 02:08 PM Re: Firefox upgrades: crazy [Re: Bensheim]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: Bensheim
Do we need an upgrade or NOT? (3.6.25 here, on Snow Leopard)

confused

Yes, you do need to upgrade to take advantage of a number of security fixes etc. The thing is, when making noises about an upgrade Firefox is NOT referring to version 3.6.x, but to the current version 9.0.1. Version 3.6.25 is the final version for legacy users/equipment, but Mozilla'd like you to move to whatever is current if your CPU (Intel) allows that. If you have PPC Macs, which will not run anything beyond Firefox 3.x, you might consider the latest TenFourFox version, a Firefox derivative especially for PPC Macs.
_________________________
alternaut moderator

Top
#20348 - 01/26/12 02:14 PM Re: Firefox upgrades: crazy [Re: alternaut]
Bensheim Offline


Registered: 08/16/09
Loc: UK
Yes Firefox is in Applications, Yes all 4 Macs are Intel.

Will reconsider this tomorrow: it's nearly midnight here.

Thanks for reponses so far.


Top
#20358 - 01/26/12 03:13 PM Re: Firefox upgrades: crazy [Re: Bensheim]
Kevin M. Dean Offline


Registered: 08/04/09
Loc: Florida
Maybe just easier to download the dmg and just copy the app to upgrade.
_________________________
iMac 2.7 GHz Core i5, 12 GB RAM, OS X 10.9, Int SATA 1 TB, Ext Fire 2 TB / 1 TB / 1 TB / 500 GB / 300 GB
Former MacFixIt Forums member since 11/17/99
www.rhubarbproductions.com

Top
#20360 - 01/26/12 03:37 PM Re: Firefox upgrades: crazy [Re: alternaut]
artie505 Online


Registered: 08/04/09
Thanks for correcting me about the beta (it's 10, not 9); I lost track of which finger I was on.
_________________________
The new Great Equalizer is the SEND button.

Top
#20361 - 01/26/12 03:39 PM Re: Firefox upgrades: crazy [Re: Bensheim]
artie505 Online


Registered: 08/04/09
The question was "which version of Firefox is in /Apps?"
_________________________
The new Great Equalizer is the SEND button.

Top
#20374 - 01/27/12 07:48 AM Re: Firefox upgrades: crazy [Re: alternaut]
Bensheim Offline


Registered: 08/16/09
Loc: UK
Originally Posted By: alternaut
Originally Posted By: Bensheim
Do we need an upgrade or NOT? (3.6.25 here, on Snow Leopard)

confused

Yes, you do need to upgrade to take advantage of a number of security fixes etc. The thing is, when making noises about an upgrade Firefox is NOT referring to version 3.6.x, but to the current version 9.0.1. Version 3.6.25 is the final version for legacy users/equipment, but Mozilla'd like you to move to whatever is current if your CPU (Intel) allows that. ......


Er....... you've quoted me stating that we're all on Snow Leopard, then ask if we have PPC processors? confused

Anyway, I've downloaded Firefox 9 and installed it on one Mac to see what's what, before loading it on all the others. I don't like the new button bar at the top but I suppose I'll get used to it.

Here's another Firefox question. I have pop-ups blocked. Yet a website I have to use every day for work, shoves in a pop-up questionnaire invitation every single time I go there. I've already answered it once, and it's a long one.

Another website which I have to use every day for work, shoves in a pop-up excitedly telling (me) everyone that they've redesigned their website, click anywhere to continue.

Is there any way of stopping these nuisances?

Top
#20376 - 01/27/12 08:46 AM Re: Firefox upgrades: crazy [Re: Bensheim]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: Bensheim
Er....... you've quoted me stating that we're all on Snow Leopard, then ask if we have PPC processors? confused

[Pop-ups] Is there any way of stopping these nuisances?

Yes, I did notice you mention Snowy, implying Intel Macs. The TenFourFox info is just FYI, for completeness', not confusion's sake.

Popup blockers like FireFox's Prefs option may not be able to address every single way popups can be produced. You could try searching the Add-ons (Tools > Add-ons > Browse All Add-ons> Search) for alternatives and see if they do a better job with the ones that bother you now.

PS: Note that some sites require popup blockers to be off for full functionality. They usually mention this somewhere, but it may not be all that obvious. Something to remember when a site doesn't seem to work right.
_________________________
alternaut moderator

Top
#20380 - 01/27/12 10:24 AM Re: Firefox upgrades: crazy [Re: Bensheim]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: Bensheim
Here's another Firefox question. I have pop-ups blocked.
Is there any way of stopping these nuisances?

Blocking pop-ups via Content under FF Preferences should do it.

Top
#20381 - 01/27/12 10:41 AM Re: Firefox upgrades: crazy [Re: grelber]
Bensheim Offline


Registered: 08/16/09
Loc: UK
Originally Posted By: grelber
Originally Posted By: Bensheim
Here's another Firefox question. I have pop-ups blocked.
Is there any way of stopping these nuisances?

Blocking pop-ups via Content under FF Preferences should do it.


This is amazing. This happens to me all the time.

I make a statement, e.g., I have pop-ups blocked, and someone responds with "blocking pop-ups should do it".

Earlier on, I stated that we are on Snow Leopard. Then I was asked if we were on non-Intel Macs.

If I'm doing something "wrong" with my posts, what the heck is it?

<shakes head and wanders off, again>

Top
#20382 - 01/27/12 10:49 AM Re: Firefox upgrades: crazy [Re: Bensheim]
artie505 Online


Registered: 08/04/09
Well, by the same token, I posted

Quote:
I'm running Firefox 8.0, and there's a 9.x beta out there, so something sounds wacky, like have you maybe got two different versions of Firefox in two different locations? (What does a command-I on Firefox in your apps folder tell you?)

and dkmarsh posted

Quote:
You might try clicking and holding on the running Firefox's Dock icon, then choosing Show in Finder from the contextual menu...just to be sure that the Firefox you're running is indeed located in /Applications.

and the best you could come back with was

Quote:
Yes Firefox is in Applications [....]

which was not responsive to either question.
_________________________
The new Great Equalizer is the SEND button.

Top
#20384 - 01/27/12 11:18 AM Re: Firefox upgrades: crazy [Re: artie505]
Bensheim Offline


Registered: 08/16/09
Loc: UK
I really shouldn't go down this trail, but since I have 5 minutes to spare,

I don't see how, artie, my response failed to answer the question posed. You said wtteo 'where is it', dkm asked wtteo 'is it in Applications'. I replied with what you have re-posted.

confused

Top
#20385 - 01/27/12 11:54 AM Re: Firefox upgrades: crazy [Re: Bensheim]
artie505 Online


Registered: 08/04/09
Originally Posted By: Bensheim
I really shouldn't go down this trail, but since I have 5 minutes to spare,

I don't see how, artie, my response failed to answer the question posed. You said wtteo 'where is it', dkm asked wtteo 'is it in Applications'. I replied with what you have re-posted.

confused

Sorry, nope... I asked you to do a command-I to determine which version of Firefox you had in /Apps, and dk asked you to check whether the Firefox icon in your Dock was, indeed, connected to the version of Firefox in /Apps, and you responded to neither question.
_________________________
The new Great Equalizer is the SEND button.

Top
#20386 - 01/27/12 12:27 PM Re: Firefox upgrades: crazy [Re: Bensheim]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: Bensheim
This is amazing. This happens to me all the time.
Earlier on, I stated that we are on Snow Leopard. Then I was asked if we were on non-Intel Macs.
If I'm doing something "wrong" with my posts, what the heck is it?

Just to reiterate, I didn't ask you anything, I just provided info. So perhaps you read too much into certain posts. Alternatively, you may not read them well enough, something that's apparently fairly common in that it may also apply to others here. That happens, no big whoop. Bottom line, let's all cool down and focus on the issue(s) at hand.

Whenever you have some time, please let us know what happened with the few suggestions made so far.

_________________________
alternaut moderator

Top
#20388 - 01/28/12 12:39 AM Re: Firefox upgrades: crazy [Re: Bensheim]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: Bensheim
Originally Posted By: grelber
Originally Posted By: Bensheim
Here's another Firefox question. I have pop-ups blocked.
Is there any way of stopping these nuisances?

Blocking pop-ups via Content under FF Preferences should do it.


This is amazing. This happens to me all the time.

I make a statement, e.g., I have pop-ups blocked, and someone responds with "blocking pop-ups should do it".

Earlier on, I stated that we are on Snow Leopard. Then I was asked if we were on non-Intel Macs.

If I'm doing something "wrong" with my posts, what the heck is it?

<shakes head and wanders off, again>


My appreciation of your query was off-track. Mea culpa. Since your comment didn't specifically state so, I read it as you're having used a non-integral/non-FF ad blocker (such as many in the forums have talked about).

Top

Moderator:  alternaut, dianne, MacManiac