An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#20254 - 01/23/12 05:22 PM Upgrading from 10.4
deniro Offline


Registered: 09/09/09
My sister would like to upgrade from 10.4.11 in order to use the itunes store again and QVC. Is it still possible to upgrade to 10.5? Or would she have to jump to Lion? I'm suspicious of Lion myself.

My understanding is that 10.5 and later are Intel only.

Where would I find info about this and possibly purchase an upgrade?
Have you ever noticed how hard it is to find basic info on the Apple site?
_________________________
OS X 10.11.6
iMac 21.5", Mid 2011
2.8 GHz Intel Core i7, 24 GB
AMD Radeon HD 6770M
Using Apple computers since 1980

Top
#20255 - 01/23/12 05:42 PM Re: Upgrading from 10.4 [Re: deniro]
artie505 Online


Registered: 08/04/09
Originally Posted By: deniro
My sister would like to upgrade from 10.4.11 in order to use the itunes store again and QVC. Is it still possible to upgrade to 10.5? Or would she have to jump to Lion? I'm suspicious of Lion myself.

My understanding is that 10.5 and later are Intel only.

Where would I find info about this and possibly purchase an upgrade?
Have you ever noticed how hard it is to find basic info on the Apple site?

1. OS X 10.5 (Leopard) will run on either a PPC or Intel Mac (Edit: as long as the Mac in question shipped with either Leopard or an earlier version of OS X); 10.6 (Snow Leopard) is the first version of OS X that will run on Intel Macs only. Which particular Mac is your sister running?

2. Snow Leopard and Lion upgrades can be purchased directly from Apple (Edit: relatively inexpensively), but Leopard upgrade discs are available only on the Internet (Edit: and tend to be pretty pricey).

3. The latest version of iTunes is Leopard compatible, so the iTunes Store shouldn't be an issue, but I've -0- idea about QVC.

4. If you're not already doing this, you may have better luck finding info on Apple's Web site if you enter your search term in a Google window and follow it with (space)site:apple.com.

Hope this helps. smile


Edited by artie505 (01/23/12 05:49 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20256 - 01/23/12 06:12 PM Re: Upgrading from 10.4 [Re: deniro]
joemikeb Online

Moderator

Registered: 08/04/09
Loc: Fort Worth, Texas
Your sister will not be able to purchase either OS X 10.5 (Leopard) or 10.6 (Snow Leopard) from Apple or other normal retail channels. Both are obsolete products. She might be able to find copies on eBay or at one of the on line stores specializing in old Macs, but there are precautions especially when buying from eBay. Be prepared to pay a premium price for these out of date operating systems.
  1. You must purchase a retail (black disk) version of OS X. The OEM (grey disk) versions that shipped in the box with a new Mac will only work on the specific Mac model they shipped with.
  2. Leopard (OS X 10.5) has both Intel and Power PC code
  3. Snow Leopard (OS X 10.6) and Lion (OS X 10.7) are only available for Macs with an Intel processor
  4. The Mac App Store is only compatible with OS X 10.6.6 or later.
  5. Lion (OS X 10.7) is very stable and very reliable. I have upgraded my wife, my sister, my daughter, my grandson, and my son-in-law to Lion and the number of phone calls for help have fallen to almost zero.
  6. Information on the Apple web site, not surprisingly is focused on currently shipping products, but their support knowledge base and forums go back several years. The trick is knowing how to search for the information you are looking for.

IMHO, if your sister has a Mac with an Intel processor she would be better off technically and financially upgrading to Lion.
_________________________
joemikeb • moderator

Top
#20257 - 01/23/12 06:21 PM Re: Upgrading from 10.4 [Re: joemikeb]
artie505 Online


Registered: 08/04/09
> Your sister will not be able to purchase either OS X 10.5 (Leopard) or 10.6 (Snow Leopard) from Apple or other normal retail channels. Both are obsolete products.

Correction... Snow Leopard is still available from Apple Store (U.S.) for the same $29 as always, presumably because of the requirement that you must be running Snow Leopard to upgrade to Lion in at least some instances.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20274 - 01/24/12 01:35 PM Re: Upgrading from 10.4 [Re: artie505]
deniro Offline


Registered: 09/09/09
Can you go from Tiger to Snow Leopard or do you need Leopard first?

Can you go from Tiger to Lion without intervening updates?

I'm getting the specs on her laptop.
_________________________
OS X 10.11.6
iMac 21.5", Mid 2011
2.8 GHz Intel Core i7, 24 GB
AMD Radeon HD 6770M
Using Apple computers since 1980

Top
#20275 - 01/24/12 01:54 PM Re: Upgrading from 10.4 [Re: deniro]
artie505 Online


Registered: 08/04/09
Originally Posted By: deniro
Can you go from Tiger to Snow Leopard or do you need Leopard first?

Can you go from Tiger to Lion without intervening updates?

I'm getting the specs on her laptop.

Hmmm... I believe you can go directly from Tiger to Snow Leopard, but you'd better wait for a "definite" reply.

As for Lion... If your sister has an Intel Mac and is running Tiger, there's a chance that her Mac is not up to Lion specs, particularly:

Originally Posted By: Apple
General requirements

Mac computer with an Intel Core 2 Duo, Core i3, Core i5, Core i7, or Xeon processor

If she is up to specs, she must install Snow Leopard before she can upgrade to Lion via the Mac App Store; she may be able to avoid Snow Leopard with the OS X Lion USB Thumb Drive, but I don't think trying to go from Tiger to Lion would be a very good idea.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20306 - 01/25/12 04:35 PM Re: Upgrading from 10.4 [Re: artie505]
deniro Offline


Registered: 09/09/09
Here are the specs. What are my options?

OS 10.4.11
Machine Name: iBook G4
Machine Model: PowerBook6,7
CPU Type: PowerPC G4 (1.5)
Number Of CPUs: 1
CPU Speed: 1.42 GHz
L2 Cache (per CPU): 512 KB
Memory: 512 MB
Bus Speed: 142 MHz
Boot ROM Version: 4.9.3f0
_________________________
OS X 10.11.6
iMac 21.5", Mid 2011
2.8 GHz Intel Core i7, 24 GB
AMD Radeon HD 6770M
Using Apple computers since 1980

Top
#20309 - 01/25/12 04:46 PM Re: Upgrading from 10.4 [Re: deniro]
artie505 Online


Registered: 08/04/09
Originally Posted By: deniro
Here are the specs. What are my options?

CPU Type: PowerPC G4 (1.5)

That's the key line; it means that your sister cannot go any further in OS X than 10.5.8 Leopard, since both Snow Leopard and Lion are Intel only.

Her only option other than upgrading her Mac is purchasing a Leopard Retail, i.e. universal install disc; they have been going on eBay for in the range of $140/$150 recently. (Be certain to heed joemikeb's caveats.)

Edit: As far as Leopard goes, it's worth noting that
  • Apple no longer supports Safari for Leopard, although the final version does support extensions.
  • Apple still supports iTunes for Leopard, but there's no way of knowing how long that will continue.


Edited by artie505 (01/25/12 04:56 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20310 - 01/25/12 07:36 PM Re: Upgrading from 10.4 [Re: deniro]
alternaut Offline
Moderator

Registered: 08/04/09
There is another consideration you may want to take into account. Even though your sister's iBook is still officially supported, it will phase through the 'vintage' stage into 'obsolescence' within the next 2 years. But as it is, Apple already isn't supporting Leopard with security updates any longer, and various other web-related software is no longer updated either. If you depend on any of this for secure web connections, you must realize that a lot of it has already been compromised. For this reason many web sites require Intel-based Macs to run their client apps.

I can say this from my own experience working mostly on a last model G5 iMac. It's only because of several Intel based MacBooks in the household that I can do those things the PPC Mac won't allow me any longer. Suffice it to say that I'm thinking more and more about upgrading my work horse Mac. Meanwhile, iTunes will run fine under Leopard accessing the iTunes Store, and so will access to QVC (although I haven't tried to register there). But that may change with the next iteration of Mac OS X or iTunes, and quite likely by the time these PPC Macs fade into official obsolescence (late 2013).
_________________________
alternaut moderator

Top
#20315 - 01/25/12 11:21 PM Re: Upgrading from 10.4 [Re: alternaut]
artie505 Online


Registered: 08/04/09
> For this reason many web sites require Intel-based Macs to run their client apps.

Would you please clarify "their client apps?"

Thanks.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20320 - 01/26/12 03:00 AM Re: Upgrading from 10.4 [Re: deniro]
jchuzi Online


Registered: 08/04/09
Loc: New York State
Originally Posted By: deniro
Here are the specs. What are my options?

OS 10.4.11
Machine Name: iBook G4
Machine Model: PowerBook6,7
CPU Type: PowerPC G4 (1.5)
Number Of CPUs: 1
CPU Speed: 1.42 GHz
L2 Cache (per CPU): 512 KB
Memory: 512 MB
Bus Speed: 142 MHz
Boot ROM Version: 4.9.3f0
If you spend the money to upgrade to Leopard, you need more RAM. That Mac will take up to 1.5 GB. Actually, it's a good idea even if you keep 10.4.
_________________________
Jon

OS 10.14.6, iMac Retina 5K 27-inch, late 2014, 3.5 GHz Intel Core i5, 1 TB fusion drive, 16 GB RAM, Epson SureColor P600, Photoshop CC, Lightroom CC, MS Office 365

Top
#20321 - 01/26/12 03:17 AM Re: Upgrading from 10.4 [Re: jchuzi]
artie505 Online


Registered: 08/04/09
Good catch, Jon.

Problem is that deniro's sister can't function fully with Tiger...needs at least Leopard.

If you add the cost of RAM to that of a Leopard disc, her best, although not least expensive, bet is to spring for a new(er) Mac as per alternaut.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20323 - 01/26/12 05:08 AM Re: Upgrading from 10.4 [Re: artie505]
dkmarsh Offline

Moderator

Registered: 08/04/09

Not sure about the math. If a Leopard disc sells for $150, it's kind of a gray area as to whether the forty bucks for a gig of RAM for an iBook G4 constitutes a deal-breaker.
_________________________

dkmarsh • member, FineTunedMac Co-op Board of Directors

Top
#20325 - 01/26/12 07:20 AM Re: Upgrading from 10.4 [Re: dkmarsh]
deniro Offline


Registered: 09/09/09
As soon as I saw that she had a PPC, I thought, uh-oh, new Mac on the way...


Edited by deniro (01/26/12 07:22 AM)
_________________________
OS X 10.11.6
iMac 21.5", Mid 2011
2.8 GHz Intel Core i7, 24 GB
AMD Radeon HD 6770M
Using Apple computers since 1980

Top
#20327 - 01/26/12 08:14 AM Re: Upgrading from 10.4 [Re: artie505]
alternaut Offline
Moderator

Registered: 08/04/09
Originally Posted By: artie505
Would you please clarify "their client apps?"

Those programs (or minimum versions thereof) required to access web sites (like browsers), and specifically certain functionality there. You see this for example with banks and financial institutions, particularly those requiring security dongles, which tend to come with special drivers.

So, if the minimum browser version and/or the dongle's driver require an Intel Mac, you're out of luck with a PPC Mac.
_________________________
alternaut moderator

Top
#20331 - 01/26/12 10:46 AM Re: Upgrading from 10.4 [Re: alternaut]
artie505 Online


Registered: 08/04/09
Thanks for the clarification.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20334 - 01/26/12 11:50 AM Re: Upgrading from 10.4 [Re: dkmarsh]
artie505 Online


Registered: 08/04/09
Originally Posted By: dkmarsh
Not sure about the math. If a Leopard disc sells for $150, it's kind of a gray area as to whether the forty bucks for a gig of RAM for an iBook G4 constitutes a deal-breaker.

The extra forty bucks isn't necessarily a deal-breaker, but together with the abstract psychological "that, too, and all to perpetuate an almost obsolete and already non-fully-functional machine" cost, yeah... I think it may be a deal-breaker.


Edited by artie505 (01/26/12 11:52 AM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#20352 - 01/26/12 02:25 PM Re: Upgrading from 10.4 [Re: deniro]
Virtual1 Offline


Registered: 08/04/09
Loc: Iowa
just confirming that snow discs are still available from Apple. But they've been yanked from many of their retail stores, and you are unlikely to find them at any 3rd party channels like local apple authorized resellers.

we on the other hand, I told my mgr to buy up to 100 of them if he could get his hands on them. And so we did. And we are having NO problem selling them, since not even the nearest Apple store carries them. craaazy.
_________________________
I work for the Department of Redundancy Department

Top

Moderator:  dianne, dkmarsh, joemikeb