An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Page 1 of 2 1 2 >
Topic Options
#17576 - 09/24/11 08:01 PM Updated UBB.threads™ software
artie505 Offline


Registered: 08/04/09
My immediate impression is that UBB.threads™ PHP Forum Software 7.5.6p1 is snappier than its predecessor.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#17577 - 09/24/11 08:07 PM Re: Updated UBB.threads™ software [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
I'm getting the same feeling. The upgrade seems lightning-fast from here.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#17578 - 09/24/11 08:19 PM Re: Updated UBB.threads™ software [Re: tacit]
artie505 Offline


Registered: 08/04/09
Originally Posted By: tacit
I'm getting the same feeling. The upgrade seems lightning-fast from here.

Second the "lightning-fast," but I didn't want to be too exuberant in the first five minutes, and in the middle of the night, to boot.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#17579 - 09/24/11 09:38 PM Re: Updated UBB.threads™ software [Re: tacit]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: tacit
The upgrade seems lightning-fast from here.

Same thing here on my iPod. Impressive! tongue
_________________________
alternaut • moderator

Top
#17580 - 09/24/11 11:38 PM Re: Updated UBB.threads™ software [Re: alternaut]
artie505 Offline


Registered: 08/04/09
Originally Posted By: alternaut
alternaut • moderator

Problem with your sig, or is the humorous intent whizzing high above my head?

Note: Where do the new smilies fit in? Got it! (Are they really necessary in this context?)


Edited by artie505 (09/24/11 11:54 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#17582 - 09/25/11 01:31 AM Re: Updated UBB.threads™ software [Re: artie505]
cyn Offline

Administrator

Registered: 08/03/09
Am guessing you're referring to the Posting Icon smilies, Artie. Those are part of the default UBBT 7.x package...and I've once again removed them.

The bullet in alternaut's sig not displaying correctly was 'cause the charset had reverted to iso-8859-1 (happens every upgrade/update). I've changed it back to UTF-8.
_________________________
FineTunedMac Forums Admin

Top
#17585 - 09/25/11 01:57 AM Re: Updated UBB.threadsďż˝ software [Re: cyn]
artie505 Offline


Registered: 08/04/09
Originally Posted By: cyn
1. Am guessing you're referring to the Posting Icon smilies, Artie. Those are part of the default UBBT 7.x package...and I've once again removed them.

2. The bullet in alternaut's sig not displaying correctly was 'cause the charset had reverted to iso-8859-1 (happens every upgrade/update). I've changed it back to UTF-8.

1. I noticed that you'd done that before I saw your post. (Those smilies were totally out of context here.)

2. Yeah... I remember the same thing happening last time. (With respect to 1., too.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#17625 - 09/26/11 12:56 PM Re: Updated UBB.threadsďż˝ software [Re: cyn]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Originally Posted By: cyn
The bullet in alternaut's sig not displaying correctly was 'cause the charset had reverted to iso-8859-1 (happens every upgrade/update). I've changed it back to UTF-8.


Hmm. I missed that. Good catch!
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#17629 - 09/26/11 01:23 PM Re: Updated UBB.threadsďż˝ software [Re: tacit]
alternaut Offline

Moderator

Registered: 08/04/09
I noticed it too on the 'Pod, and recognized it as a recurrence, the fixing of which is beyond mere mods. smirk On top of that, my 'Pod use around that time of day always ends with listening to audiobooks which invariably puts me to sleep. Upon waking cyn had taken care of things as on previous occasions. tongue
_________________________
alternaut • moderator

Top
#17636 - 09/26/11 05:49 PM Re: Updated UBB.threadsďż˝ software [Re: alternaut]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Another security update, 7.5.6p2, was just released today. Installation was a breeze (only a few files were affected), and it seems to be operating correctly.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#17942 - 10/05/11 12:55 PM Re: Updated UBB.threadsďż˝ software [Re: cyn]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: cyn
The bullet in alternaut's sig not displaying correctly was 'cause the charset had reverted to iso-8859-1 (happens every upgrade/update). I've changed it back to UTF-8.

I noticed that question marks have been inserted for certain characters in some thread titles. What's up with that? Examples:

- Re: Microsoft Word 2011 ��... (currently at the top of the Mac OS X Application forum, as seen at the Forum List level)
- Updated UBB.threadsďż˝ software (as listed in FineTunedMac Feedback)
_________________________
alternaut • moderator

Top
#17944 - 10/05/11 01:13 PM Re: Updated UBB.threadsďż˝ software [Re: alternaut]
artie505 Offline


Registered: 08/04/09
I don't know what's up with the "Word" thread, but in this thread the question mark replaces the ™ that I typed.


Edited by artie505 (10/05/11 01:16 PM)
Edit Reason: Cleanup
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#17946 - 10/05/11 01:41 PM Re: Updated UBB.threads™ software [Re: artie505]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: artie505
...in this thread the question mark replaces the ™ that I typed.

Within the posts it does so for me too, but not in the post titles, except in the title of this reply where I manually changed it. I suspect it'll be fine in replies to this post as well.

In the 'Word' thread the substitution is only visible in the title at Forum List level, not within that forum itself. It's got to be some sort of character set issue, despite the fact that it doesn't seem consistent. Perhaps there was a (transient?) glitch during the character set change, or the subsequent page rendering.


PS, the substitution in this thread might be explained by the time of the first occurrence, on the day the UBB.threads update was installed, but before the character set change by cyn. All subsequent occurrences were just inherited, not created anew. But this explanation doesn't fly with the Word thread, unless there was character set hanky-panky around the time of the first post there as well (~ 8AM, 10/05/11).
_________________________
alternaut • moderator

Top
#17948 - 10/05/11 02:05 PM Re: Updated UBB.threads™ software [Re: alternaut]
artie505 Offline


Registered: 08/04/09
Originally Posted By: alternaut
Originally Posted By: artie505
...in this thread the question mark replaces the ™ that I typed.

Within the posts it does so for me too, but not in the post titles, except in the title of this reply where I manually changed it. I suspect it'll be fine in replies to this post as well.

PS, the substitution in this thread might be explained by the time of the first occurrence, on the day the UBB.threads update was installed, but before the character set change by cyn. All subsequent occurrences were just inherited, not created anew. But this explanation doesn't fly with the Word thread, unless there was character set hanky-panky around the time of the first post there as well (~ 8AM, 10/05/11).


I just started a new thread, and the ™ came through, so I guess your guess is correct.

I'd appreciate your clarifying "Within the posts it does so for me too, but not in the post titles".

Thanks.

Edit: Hmmm... There was the security update to the security update that tacit mentioned, but I've got -0- idea when it was installed.


Edited by artie505 (10/05/11 02:16 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18061 - 10/07/11 04:02 PM Re: Updated UBB.threads™ software [Re: artie505]
Hal Itosis Offline


Registered: 09/03/09
Loc: 10.6.8 (build 10K549)
Hmm... i've just been observing a generic favicon here, while this thread proceeded. Then just 3 minutes ago, i'm now getting the custom "Mac/Man" FTM icon... all with no effort on my part. [i.e., haven't monkeyed with WebpageIcons.db for the past week.]

idunno

Top
#18076 - 10/07/11 06:11 PM Re: Updated UBB.threads™ software [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
The second p2 security update was installed the day after the p1 security update was installed.

I am now seeing the correct favicon, though I did nothing on the server, so I have no idea why.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#18079 - 10/07/11 06:22 PM Re: Updated UBB.threads™ software [Re: tacit]
alternaut Offline

Moderator

Registered: 08/04/09
Interesting. Sometime today my 'fuzzy' version of the FTM favicon morphed into the 'good' one without special effort on my part.
_________________________
alternaut • moderator

Top
#18086 - 10/08/11 12:51 AM Re: Updated UBB.threads™ software [Re: tacit]
artie505 Offline


Registered: 08/04/09
> The second p2 security update was installed the day after the p1 security update was installed.

Thanks.

Then it has nothing to do with the ??? in Alex's post of 10-5.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18087 - 10/08/11 12:54 AM Re: Updated UBB.threads™ software [Re: alternaut]
artie505 Offline


Registered: 08/04/09
Originally Posted By: alternaut
Interesting. Sometime today my 'fuzzy' version of the FTM favicon morphed into the 'good' one without special effort on my part.

That's three mysterious occurrences within 2 1/2 hours...most mystifying, particularly when put into context with the almost immediate appearance of the correct favicon on my deuced Mac(hina). confused
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18093 - 10/08/11 09:26 AM Re: Updated UBB.threads™ software [Re: artie505]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: artie505
Then it has nothing to do with the ??? in Alex's post of 10-5.

No, it hasn't. The fact that both the timing of the updates and the charset change preceded the generation of the Word thread character florf is only one of the two reasons I considered that this issue was caused by something else. The other factor was the location of the off-character: at the Forum List level. The thread titles there are pulled from the threads themselves by the UBB.threads software.

I would think that for a wrong character to appear at the Forum List level*, that wrong character must first be present in the thread in question, AND that it should remain in that thread until it's fixed manually. There's nothing wrong with the thread title within the forum, so unless it was fixed there afterward I cannot explain this particular issue other than by a glitch in the Forums software. Obviously, since the Word thread is no longer the last thread posted to in Mac OS X Applications, the issue has vanished from sight.

*) Titles at the Forum List level cannot be edited by mods, as opposed to the threads themselves.
_________________________
alternaut • moderator

Top
#18094 - 10/08/11 09:32 AM Re: Updated UBB.threads™ software [Re: alternaut]
artie505 Offline


Registered: 08/04/09
Thanks for the explanation of why there's no explanation.

I dunno... I've seen those ??? any number of times in the past, but I never thought enough of them to post.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18102 - 10/08/11 05:47 PM Re: Updated UBB.threads™ software [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Originally Posted By: artie505
Thanks for the explanation of why there's no explanation.

I dunno... I've seen those ??? any number of times in the past, but I never thought enough of them to post.


I believe, though I haven't dug through the source code enough to confirm, that there is actually a text encoding bug in UBB. It seems that the code which generates lists of threads in UBB doesn't respect the current setting for character encoding, but the code in UBB that is responsible for displaying posts does.

The short and not-too-technical root of the problem is that there is an accepted international standard way of assigning all the "regular" characters of the English language and all the standard punctuation marks you see printed on a keyboard; for example, a space is always represented by the number 32, the uppercase letter P is always represented by the number 80, and so on.

But when it comes to accented characters, foreign-language characters, special punctuation like smart (curly) quotes, special symbols like the trademark or registered trademark symbol, and things like that, there's no accepted standard way to represent them. There are actually a bunch of different, competing standards: ISO Latin, MacRoman, UTF-8, UTF-16, and so forth.

Naturally, they're entirely different. In ISO Latin, the registered trademark symbol is assigned the number 174. In UTF-8, it's represented by the number 49838 (UTF uses two-byte numbers for special characters).

Normally, the browser and the Web page communicate with each other to tell one another which standard they're using. You can tell UBB which standard to use, and then UBB will tell the browser which standard it's using. If you change the standard you're using, UBB will change stuff around accordingly. But if something goes wrong, which it seems to when UBB tells the browser it's using one standard and then sends post titles using a different standard, the browser will display the wrong character, or the special ? symbol to indicate it can't figure out what that character is.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#18108 - 10/08/11 11:42 PM Re: Updated UBB.threads™ software [Re: tacit]
artie505 Offline


Registered: 08/04/09
Clear, concise, and well-stated explanation... As usual.

Thanks.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18180 - 10/10/11 10:18 PM Re: Updated UBB.threads™ software [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
OK, I've dug some more and discovered precisely what's happening. We have FineTunedMac set to use the UTF standard for special characters. However, the characters that you're seeing as ? symbols in post titles are being sent out as ISO Latin. Even though UBB is using the UTF character encoding, it's still sending out post topics using ISO Latin, which is where the problem is coming from
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#18181 - 10/10/11 11:23 PM Re: Updated UBB.threads™ software [Re: tacit]
artie505 Offline


Registered: 08/04/09
Originally Posted By: tacit
OK, I've dug some more and discovered precisely what's happening. We have FineTunedMac set to use the UTF standard for special characters. However, the characters that you're seeing as ? symbols in post titles are being sent out as ISO Latin. Even though UBB is using the UTF character encoding, it's still sending out post topics using ISO Latin, which is where the problem is coming from

Which, presumably, calls for UBB intervention?
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
Page 1 of 2 1 2 >

Moderator:  alternaut, cyn, dkmarsh