An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#18038 - 10/07/11 10:23 AM Firefox 7 (related to Word and QuickTime)
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
To the moderator: I'm posting this under the browsers forum even though there are ancillary issues which might properly be posted to other forums. Please relocate the post if it seems to be misplaced here.

OK. The stormy seas are beginning to calm, and the sailing is getting a bit smoother. However, at least a few niggling problems remain to interfere with my computing pleasure ...

Running Firefox 7.0 in OS 10.7.1:
When I cut some text from a newspaper article or some such in which there are one or more hyperlinks and paste the selection into a (new/blank) Word 2011 document, the hyperlinks are 'active', meaning highlighted and underlined.

I don't want such – just the text – which is just how it worked with my old iMac DV SE running OS 9.0.4 and Word 98.

I've gone over the Preferences for Word and Firefox repeatedly to toggle that feature off ... to no avail.

Does anyone have a clue how to deal with this?


Likewise in Firefox:
Is there some way to allow Web pages to appear early on in the loading process? With my dial-up access (56K V.92 USB modem) it often waits until 80-90% of the page has been acquired before showing up and then finishing the process. So, eg, opening a newspaper's website (such as The New York Times) produces a blank window until ca 80% of the page is loaded. [I suspect that it might have to do with the huge amount of graphics that accompanies the page, but I don't want to block images completely, since I want to see the pictures associated with the news articles (but not images associated with sidebar ads and such).] Can any of this be altered? And if so, how and where?


A similar problem holds true for QuickTime:
When selecting a 'movie' (usually an mpeg) for viewing within a Web page, the entire item downloads into the computer before it will play. In my old iMac running OS 9.0.4 and QuickTime 6.0.2, such mpegs would load partially and begin playing well before the download was complete. Can this be adjusted in my new set-up?

Also in the new iMac the Download progress panel shows up every time something is implicitly and explicitly being downloaded. Most annoying. How do I alter that behavior?

I'd be grateful for any resolutions to the above issues.


Top
#18042 - 10/07/11 11:14 AM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
alternaut Offline

Moderator

Registered: 08/04/09
I'm not sure if it's always possible to alter the copy properties in various apps (I don't recall seeing such options in prefs), but in case this won't work in the situations you'd like it to, I'd recommend Plain Clip (freeware). I've been using this utility for years to strip formatting from text on the clipboard. You drag its icon to the dock, and click on it after you copy and before you paste. More filter options can be accessed via its prefs.

Again, I'm not sure if you can change a browser's page display details relative to the loading process. You can, however, stop various page elements from showing/downloading until you know you actually want them. There are adblockers like Adblock Plus (see Firefox Add-ons or Safari Extensions). In addition, Safari has a pair of great extensions that block flash or other items requiring plugins for display: ClickToFlash and ClickToPlugin, allowing you to manually click them back on. (Btw, any reason you're not using Safari?)

Likewise, I don't think you can control QT's display relative to the download status of a clip. Contrary to yours, my experience is that QT starts playing well before a clip has come in completely, as judged by the progress bar below the video window.

Finally, you can toggle Firefox's Downloads window on and off in its General preferences panel, but I haven't checked v7. AFAIK, Safari won't allow that (at least up to v.5.0.6), but there may be an extension that does the trick.
_________________________
alternaut moderator

Top
#18045 - 10/07/11 11:24 AM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
artie505 Online


Registered: 08/04/09
> Also in the new iMac the Download progress panel shows up every time something is implicitly and explicitly being downloaded. Most annoying. How do I alter that behavior?

Yeah... At 56K your d/l's last a while; I can see why you'd get annoyed.

If nothing else, Firefox may have a keyboard command to hide/show the d/l window (similar Safari's command-option-L).

Edit: Refer to alternaut, too.


Edited by artie505 (10/07/11 11:25 AM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#18046 - 10/07/11 11:30 AM Re: Firefox 7 (related to Word and QuickTime) [Re: alternaut]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Thanks for the pointers. It was worth a shot to see if anything could be done regarding those issues. I'll look into Plain Clip.

Originally Posted By: alternaut
(Btw, any reason you're not using Safari?)

Over the years, whenever I've used Safari on others' OS X computers, I haven't liked the experience. So, just my long-time preference for Mozilla's products. Together, Firefox and Thunderbird give me exactly (well, more or less) what I had with straight Mozilla OS 9 — warm and fuzzy, if you know what I mean.

EDIT: Now my avatar's back to strolling. [Refer to my last post in iCal and PandoCalendar thread.]


Edited by grelber (10/07/11 11:35 AM)
Edit Reason: Avatar alive and well

Top
#18047 - 10/07/11 12:30 PM Re: Firefox 7 (related to Word and QuickTime) [Re: alternaut]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Another sticky wicket:

I tried to access the Help Center at mozilla.org to get help for an issue re Thunderbird, namely how to open a document and it replied that I wasn't connected to the Internet (which I obviously am). So, I'm back here ...

I have several email documents which saved themselves automatically to .eml files. Now there seems to be no application to open them, although I'm sure there's one in here somewhere – it just hasn't been selected/assigned to open such files.

Firefox has a list of applications to handle various things, but documents with the extension .eml isn't one of them.

Word can't handle it either.

Again, am I missing something? Or is there an application out there that I can drop into Thunderbird (or any place on my iMac) to be able to open these .eml files?

Top
#18048 - 10/07/11 12:44 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
jchuzi Offline


Registered: 08/04/09
Loc: New York State
I have Office 2008 and the default application for .eml files is Entourage. In Office 2011, Outlook replaces Entourage; perhaps Outlook will work for you. Also, Mail is listed as a possible application for those files. BTW, I'm using RCDefaultApp.

If you do a Get Info on a .eml file (or control-click it and select Open With), what does it say?
_________________________
Jon

OS 10.14.3, iMac Retina 5K 27-inch, late 2014, 3.5 GHz Intel Core i5, 1 TB fusion drive, 16 GB RAM, Epson SureColor P600, Photoshop CC, Lightroom CC, MS Office 365

Top
#18049 - 10/07/11 12:58 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
Hal Itosis Offline


Registered: 09/03/09
Loc: 10.6.8 (build 10K549)
Originally Posted By: grelber
When I cut some text from a newspaper article or some such in which there are one or more hyperlinks and paste the selection into a (new/blank) Word 2011 document, the hyperlinks are 'active', meaning highlighted and underlined.

I don't want such – just the text – which is just how it worked with my old iMac DV SE running OS 9.0.4 and Word 98.

I've gone over the Preferences for Word and Firefox repeatedly to toggle that feature off ... to no avail.

Well it wouldn't be in Firefox, as one of the primary purposes of a browser is to support hyperlinks. But why are you using Word? If deactivating links is so difficult to achieve (with a big monster word processor like that), then maybe Pages or even TextEdit would be a wiser choice.

[Word 4.0 was a "nice" program. After that, pure bloatware.]

edit: e.g., in TextEdit we control-click the link and select 'remove link'.


Edited by Hal Itosis (10/07/11 01:00 PM)

Top
#18051 - 10/07/11 01:22 PM Re: Firefox 7 (related to Word and QuickTime) [Re: jchuzi]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: jchuzi
If you do a Get Info on a .eml file (or control-click it and select Open With), what does it say?


It says open in Mail. So I switched it to Firefox (as default for that type of file), selected change all that type files, and tried opening it. At which point everything went berserk: It opened up (empty) every single file on my computer; I hadto force quit and restore Firefox. Not very auspicious. Now I have clear all these open docs off my Desktop.

Top
#18052 - 10/07/11 01:25 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
When might one find a QuickTime 7 plug-in for Firefox? That seems to be missing from the helper applications. I tried Apple and Mozilla, and while they claim that what they're offering is a plug-in, it's just the whole QT application.
This is just crazy-making.

Top
#18056 - 10/07/11 02:43 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: grelber
It says open in Mail. So I switched it to Firefox (as default for that type of file), selected change all that type files, and tried opening it. At which point everything went berserk

Firefox cannot open .eml files, as indicated above. If you want to switch the opening app for a particular file type wholesale, you might want to try first if it actually produces a result you can live with. On a single file, unless you like berserk... But in this case you must have done something else to actually open all those files, like selecting all of them before hitting Open.
_________________________
alternaut moderator

Top
#18057 - 10/07/11 02:47 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
alternaut Offline

Moderator

Registered: 08/04/09
Originally Posted By: grelber
When might one find a QuickTime 7 plug-in for Firefox? I tried Apple and Mozilla, and while they claim that what they're offering is a plug-in, it's just the whole QT application.

It might help if you read the instructions: the QT plugin is part of the QT app package. Get the scoop here: Using the QuickTime plugin with Firefox.
_________________________
alternaut moderator

Top
#18063 - 10/07/11 04:08 PM Re: Firefox 7 (related to Word and QuickTime) [Re: alternaut]
dkmarsh Offline
Moderator

Registered: 08/04/09

Quote:
Likewise, I don't think you can control QT's display relative to the download status of a clip.

In OS X 10.5.8, running QuickTime 7.6.6, I see the following in the System Preferences -> QuickTime pane -> Streaming tab: an Enable Instant-On checkbox, followed by this caveat: "Instant-On starts playing streamed media without delay, but network congestion may reduce the quality of playback. Choose a longer delay if you experience problems."

Below that is a slider which allows adjustment of the delay length.

(Note that under the Browser tab in the same prefpane, there's a Play movies automatically checkbox. I imagine that's checked by default, but who knows?)

_________________________

dkmarsh • member, FineTunedMac Co-op Board of Directors

Top
#18069 - 10/07/11 04:24 PM Re: Firefox 7 (related to Word and QuickTime) [Re: alternaut]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: alternaut
It might help if you read the instructions: the QT plugin is part of the QT app package. Get the scoop here: Using the QuickTime plugin with Firefox.


I just read the info at your hotlink and I had already done all that long since (which prompted my query. There is NO plugin for QT in Firefox, despite its supposedly having been installed. So clearly the QT app did not install one.
And equally clearly, OS 10.7.1 handles such totally differently from its predecessors.
Where does one proceed from here?!
So where does one go from here?!

FYI: The only plug-ins installed in Firefox are:
Java Applet Plug-in 14.0.3
Flip4Mac Windows Media Plug-in 2.4.0.11
Shockwave Flash Plug-in 11.0.1.152
The latter two were installed automatically when I downloaded and installed their parent programs.


Edited by grelber (10/07/11 04:43 PM)
Edit Reason: Plug-ins

Top
#18070 - 10/07/11 04:32 PM Re: Firefox 7 (related to Word and QuickTime) [Re: dkmarsh]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: dkmarsh
In OS X 10.5.8, running QuickTime 7.6.6, I see the following in the System Preferences -> QuickTime pane -> Streaming tab: an Enable Instant-On checkbox, followed by this caveat: "Instant-On starts playing streamed media without delay, but network congestion may reduce the quality of playback. Choose a longer delay if you experience problems."


All well and good, I suppose, in 10.5.8, but in 10.7.1 NO such thing exists under System Preferences: QT does not appear at all in that pane. So everything downstream from there likewise does not exist.
And there are no System Preferences for QT, the application.
Your suggestions would fit the bill, if in fact 10.7.1 had such features.
What to do? What to do?

Top
#18072 - 10/07/11 05:38 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
alternaut Offline

Moderator

Registered: 08/04/09
OK, let's try something else. Can you find out which version of QT Player you're dealing with? If it's QT X 10.1 (as I suspect), try installing QT 7 as well and see if the issues* resolve themselves (both versions of QT can live together). If you installed Perian and Flip4Mac QT plugins, make sure you're up to date.

*) This *should* apply to both the QT settings as per DK's post, as well as the browser plugin.
_________________________
alternaut moderator

Top
#18075 - 10/07/11 06:09 PM Re: Firefox 7 (related to Word and QuickTime) [Re: alternaut]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
I spoke with Apple tech support and they were highly unhelpful.
EDIT: He did advise that no longer is QuickTime other than a player (ergo no user controls) and opined that it's Firefox's foible that QT plug-in (which is indeed in Internet Plugins) won't include itself among the other Firefox plug-ins.

I then followed instructions (which must have been severely out of date) at mozilla.org on how to reinstall plugin file. I should have known something was wrong. They wanted me to delete (after closing Firefox) the file in Profiles called pluginreg.dat; all I found was one called nar4skza.default, which I proceeded to delete.

When I tried to open Firefox, a ? window popped up in the middle of the screen saying there was already one copy of Firefox open and wouldn't go any further.

After mutzing about for a while, I decided there was nothing for it but to delete Firefox from the Applications (and saving that default folder) and reinstalling Firefox from scratch.

Well, that didn't work, because the same error message keeps coming up that there's another copy open.

Looking for what the computer sees led nowhere.

So here I am using Safari to try to get back my Firefox.

What can I do? I've restarted repeatedly ... to no avail.

The iMac still sees a copy of Firefox open.

I seem to be well and truly screwed.

Detailed help would be vastly more than gratefully received.

EDIT:
Sons of the beach! I futzed around some more, dropped that file back into the Profiles folder, et voilà, Firefox returned and to the status quo ante – ie, nothing seems to have changed or been lost. I then updated it to version 7.0.1; what that was/did, I haven't a clue, and there was no Read Me file to go along with it.
But still no QT (10.1) plug-in, which I'm guessing isn't there for the suggested reason alternaut gave. Again, a foible of 10.7.1.


-----

And in Safari there seems to be no way to find my imported bookmarks which are in there or to put some of them (e.g., FTM) in the Bookmark bar.
Frustrating?! Only massively.


Edited by grelber (10/07/11 06:55 PM)

Top
#18078 - 10/07/11 06:21 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Not that it matters much at this point (I imagine), but the Apple guy said there was something like archive and reinstall. There's nothing on this iMac that remotely resembles such an application. Nor in Finder's Help.

As long as I'm at it, how does one burn CDs and DVDs on this machine.
Again no instructions available (at least not where I can find/see them).

And the day started out so auspiciously, with smoother sailing and all. How quickly it all turns back to crap. The depression and neck muscle twinges are coming back with a vengeance.

Top
#18080 - 10/07/11 07:04 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
alternaut Offline

Moderator

Registered: 08/04/09
As to the mystery copy of Firefox still running, have you tried Activity Monitor (or Lion's equivalent) to see if FF shows up? If so, you can kill it from there (select>Quit Process>Force Quit). Then reinstall. That said, and unless you have it set to launch on startup, FF (or any other 3rd party app) shouldn't be running after a restart.
(Given what led or helped lead to your predicament, you may want to refrain from deleting files which are not specifically flagged for deletion in the recipes you're finding. Sooner or later you'll get into some serious trouble that way. Update: keeping them and putting them back is a standard troubleshooting approach, which your Mac-infused brain must have suggested. Keep it up!)

Missing bookmarks? Safari>Bookmarks menu>Show All Bookmarks. Check the left column for folders with 'Imported' in their title; if Safari imported your bookmarks, they gotta be here. Drag and drop your stuff where and how you want it; add new folders via the appropriate Bookmarks menu item or press Shift-Command-N.

Archive & (Re)Install is an option accessed from the Mac OS X Installer, and allows you to install a fresh copy of the OS while keeping your files and user settings intact. As Lion initially came without discs, you're supposed to use the Recovery partition on your iMac instead: reboot while holding the Command-R keys and follow the prompts.

I also have a hard time understanding why your Finder Help attempts didn't come up with anything. My trials for Archive & Install, Safari bookmark handling and CD/DVD burning returned tons of hits with appropriate info in every first doc I opened. I may not be running Lion, but it's hard to believe that Apple gutted its Help the way your comments suggest. I suppose that's because I don't know exactly what you tried.
_________________________
alternaut moderator

Top
#18084 - 10/07/11 09:16 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
cyn Offline

Administrator

Registered: 08/03/09
Dr. G., please start a separate thread for your question about burning CDs and DVDs.
_________________________
FineTunedMac Forums Admin

Top
#18096 - 10/08/11 10:05 AM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
macnerd10 Offline


Registered: 08/04/09
Loc: Los Angeles, CA
Your paste problem should be very easy to solve. Don't just "paste" or command-V. This way, the links will be active. Go to Edit>paste special and choose "unformatted text". No links should appear as highlighted. FYI, the default in paste special is HTML format explaining why you get active links in the text. Hope this helps.


Edited by macnerd10 (10/08/11 10:06 AM)
_________________________
Alex
3.1 GHz 13" MacBook Pro 2015, 8 GB RAM, OS 10.11.2, Office 2011, TimeWarner Cable
2.8 GHz Xeon Mac Pro 2010, 16 GB RAM, OS 10.11.2, Office 2011, LAN

Top
#18098 - 10/08/11 01:02 PM Re: Firefox 7 (related to Word and QuickTime) [Re: macnerd10]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Thanks. Too bad one can't do it more straightforwardly.

Top
#18100 - 10/08/11 01:24 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Following are compatibility complaints registered with Mozilla, re Firefox 7 (7.0.1) and Thunderbird 7 (7.0.1), running on iMac (Model MC309LL/A) with OS X Lion (updated to 10.7.1).

Firefox 7 will NOT:

- Access QuickTime plug-in (QuickTimePlugin.plugin), even though it is located in the system's Internet Plugins Library; attempts to add from the file fail because Firefox cannot 'see' the plugins in that Library folder (although it has access to several others, such as ShockWave).

- Even though updated to 7.0.1, the default theme has not been applied to Firefox's Appearance (and there is no way to manually accomplish such, as far as I have been able determine, even after examining Mozilla's help topics on the subject).

Thunderbird 7 will NOT open .eml documents. Apparently this bug has been known for some time and there is fix for same, but there has been no official update which takes such into account and made available to users.

Top
#18101 - 10/08/11 04:45 PM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
Hal Itosis Offline


Registered: 09/03/09
Loc: 10.6.8 (build 10K549)
Originally Posted By: macnerd10
Your paste problem should be very easy to solve. Don't just "paste" or command-V. This way, the links will be active. Go to Edit>paste special and choose "unformatted text". No links should appear as highlighted. FYI, the default in paste special is HTML format explaining why you get active links in the text. Hope this helps.

Originally Posted By: grelber
Thanks. Too bad one can't do it more straightforwardly.

On the one hand —since most folks want hyperlinks preserved —it is only right and just that those with atypical needs should be the ones who have to take the extra step.

OTOH, there may exist a slightly simpler way, of which a seasoned Word guru should be aware. [however, i haven't touched that app since 1992... so that seasoned Word guru ain't me.]

Furthermore —since text formatting doesn't seem to matter here (or at least i heard no objection about the loss of bold, italic, etc.), then —doing an ordinary ⌘V paste into a plain-text document would achieve the same end result. IOW, use the appropriate tool for the particular job. [if you don't want (or care about) formatting, then why use an app (Word) and/or document type (rtf/doc) which intentionally preserve same by default?]

Get to know TextEdit, as it is a great app that comes built-in with OS X... and it handles either plain or rich text with ease. [sorry but, using Word to save web page articles when the user doesn't desire active hyperlinks just sounds like overkill to me. And to then try to make it sound as if that's supposed to be Lion's fault somehow is even more folly.]

my .02 USD

Top
#18116 - 10/09/11 03:09 AM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
Originally Posted By: grelber
Thunderbird 7 will NOT open .eml documents. Apparently this bug has been known for some time and there is fix for same, but there has been no official update which takes such into account and made available to users.

Apparently it will open in Thunderbird 7. I just had to select that as the app to open it with rather than Mail (in the file's information page). Problem solved (at least for the time being).

Top
#18120 - 10/09/11 08:24 AM Re: Firefox 7 (related to Word and QuickTime) [Re: grelber]
grelber Offline


Registered: 08/05/09
Loc: North of 49th ||
QuickTime plugin:
I'm still in a quandary as to how I might put the QuickTime plugin (QuickTimePlugin.plugin, which is in the Library in the Internet Plugins folder) into Firefox 7 ... or at least find some way for Firefox to access it. When I try to bring it over using Firefox's plugin adding feature, it can't 'see' the plugins (ie, they're all greyed out when the Internet Plugins folder is opened).
Is there some other route one can go to achieve the desired result – without compromising safety. As noted earlier, Apple advised/warned that messing with the Library is a no-no, which is why they hid it in Lion.



Top

Moderator:  alternaut, dianne, MacManiac