An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#14626 - 03/09/11 02:03 AM Image Capture wont recognise scanner
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
Until recently I have used Image Capture very successfully to scan with a Canon MP610 multifunction printer. Simple and quite adequate for my purposes. But opening Image Capture to initiate a scan now results in an interminable delay before the printer shows up in the Devices pane on the left of the window while the message "No camera or scanner connected" is displayed in the centre pane. The delay is usually several minutes but more often as long as it takes to curse most vehemently and make a cup of coffee before stomping back to the machine.

I can't be sure but I think it started with the 10.6.5 update. I have tried several remedies suggested in other forums (deleting and re-adding the printer, resetting the printing system, changing the USB port and prayer) but to no avail. My research suggests that this issue also occurs with other brands of printer.

Perhaps 10.6.7 or Lion will fix this but, in the meantime, does anyone have any other suggestions so that I can resume digitising 30 years worth of photos?



Top
#14627 - 03/09/11 02:16 AM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
Not to be glib, but if you think it's an OS X issue, why don't you just revert to 10.6.4?

I'm not certain how much of a pain it will be for you, but...

Before you "nuke and pave" (© V1), though, try logging in to a test account to see whether your issue follows you across account lines; a "yes" suggests a system issue, while a "no" suggests an issue specific to your user account.
_________________________
The new Great Equalizer is the SEND button.

Top
#14628 - 03/09/11 02:24 AM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
Addendum: Try starting up in Safe Mode (What is Safe Boot, Safe Mode?) to do some cache clearing, etc, and then reboot and see what happens.
_________________________
The new Great Equalizer is the SEND button.

Top
#14629 - 03/09/11 02:32 AM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
"nuke and pave"? For Pete's sake what's that? Sounds a bit dire. (And who, incidently, was Pete?)

Reverting to 10.6.4 is out of the question for me - a touch too disruptive and beyond my limited technical capabilities. I like the idea of setting up a test account. Can you refer me to a simple primer on how to do this?

Top
#14630 - 03/09/11 02:36 AM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
will try this too! you posted while I was still thinking!

Top
#14631 - 03/09/11 02:38 AM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
> "nuke and pave"? For Pete's sake what's that?

"Nuke and pave" is V1's term for an erase and install. grin

To set up a test account, navigate to /Applications/System Preferences > Accounts and enable your "Guest Account." (You'll have to click on the lock.)

And don't overlook the Safe Boot; it may help.


Edited by artie505 (03/09/11 02:39 AM)
_________________________
The new Great Equalizer is the SEND button.

Top
#14632 - 03/09/11 03:23 AM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
Done the safe boot. Tried the Guest account. Goodness me, so different from my (admin) account! Unfortunately none has made any difference.

My keyboard batteries decided to die in the middle of all this...

I think I'll go to bed (in Tasmania, Australia)


Top
#14635 - 03/09/11 05:27 AM Re: Image Capture wont recognise scanner [Re: andycap]
MacManiac Online
Moderator

Registered: 08/04/09
Loc: Paradise....on the central Ore...
....and to add one more thought to Artie's list of suggestions:

I might suggest downloading and installing the Max OS X v10.6.6 Update Combo. (follow the link)

It will analyze your installed OS and replace with new ONLY the components within that it sees as needing an update.....it isn't a "nuke and pave" approach.

Sometimes, having updated the OS from sequential "delta" (single) updates, there is an opportunity to develop small dropout issues such as losing your scanner.....not saying that is exactly what transpired in your case, but the Combo updater might help and couldn't hurt.

Let us know how it goes.
_________________________
Freedom is never free....thank a Service member today.

Top
#14645 - 03/09/11 02:37 PM Re: Image Capture wont recognise scanner [Re: MacManiac]
artie505 Online


Registered: 08/04/09
Good thought...used to be one I always thought of, which, for some reason, has kind'a faded.

I hope it saves andycap from a "dreaded" reinstall of some sort.
_________________________
The new Great Equalizer is the SEND button.

Top
#14667 - 03/10/11 08:01 PM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
OK, I'll try the combo update. However this weighs in at over a gig and will take a while to download to the bottom of the world (Tasmania) (and no unkind allusions please!). I'm now so close to my download limit for this month that I might wait for the 10.6.7 Combo - kill two birds with one stone...

Top
#14671 - 03/11/11 03:19 AM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
A suggestion, if you haven't already thought of it...

Considering that you're subject to a d/l limit, whenever you d/l a Combo you ought to save it, at least until you're happy with the next one.
_________________________
The new Great Equalizer is the SEND button.

Top
#14687 - 03/11/11 05:05 PM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
I hadn't thought of it. I know lots of people with Macs (or are shortly going to get one) and they seem to think I know all about them. Hmm, not sure about that but anyway a spare combo is a dem good idea!

I think I have come up with a workaround for the Image Capture problem. Turn off the printer, fire up IC , wait 10 seconds and then turn on the printer again. I have done this several times and, after the usual printer startup clatter, it appears to recognise the scanner consistently within another 15 seconds and I can live with this. In other words, give IC a jolly good kick up the rear - initial printer/Mac communications routine perhaps?

Top
#14688 - 03/11/11 06:07 PM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
I'm happy to hear that you've come up with a workaround; maybe 10.6.7 will solve your problem.
_________________________
The new Great Equalizer is the SEND button.

Top
#14838 - 03/25/11 04:01 AM Re: Image Capture wont recognise scanner [Re: artie505]
andycap Online


Registered: 09/05/09
Loc: Hobart, Tasmania
The 10.6.7 delta update has indeed fixed this issue. Opening IC and then starting up the printer - and vice versa - now results in almost instant recognition of the scanner as a connected device. Didn't use the combo.

It's nice that I no longer gnash my teeth whenever I need to scan something but a bit disappointing that I'll never figure out why the problem arose in the first place!

Top
#14839 - 03/25/11 08:57 AM Re: Image Capture wont recognise scanner [Re: andycap]
artie505 Online


Registered: 08/04/09
Originally Posted By: andycap
It's nice that I no longer gnash my teeth whenever I need to scan something but a bit disappointing that I'll never figure out why the problem arose in the first place!

Too bad we'll never know what hit you, but I'm happy to hear that it's a thing of the past.

(Don't forget to save that Delta.)
_________________________
The new Great Equalizer is the SEND button.

Top

Moderator:  alternaut, cyn