An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Topic Options
#12100 - 09/29/10 03:19 PM Slow loading avatars
artie505 Online


Registered: 08/04/09
For the past coupl'a months (give or take) I've been experiencing an intermittent issue wherein after I click on "Submit" the page to which I've posted my response loads immediately except for the avatars which sometimes take in the range of 10-15 seconds to load.

Any ideas?
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12123 - 09/30/10 01:05 PM Re: Slow loading avatars [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Hmm. I haven't seen that issue from this end, and there's nothing in the server logs that might indicate a problem.

What ISP are you using? It's possible it could be a routing problem of some sort.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#12129 - 09/30/10 02:05 PM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
I'm using Verizon DSL with no apparent issues.

I'll try to remember to make a note of times and details when I see the slow loads; maybe it'll be helpful.

Edit: 6:33:30 PM EDT/"Generated in 0.40 seconds"/Avatars appeared 10-15 secs later.


Edited by artie505 (09/30/10 02:36 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12136 - 09/30/10 06:02 PM Re: Slow loading avatars [Re: artie505]
alternaut Offline

Moderator

Registered: 08/04/09
FWIW, I haven't seen anything like it either.
_________________________
alternaut moderator

Top
#12142 - 10/01/10 08:15 AM Re: Slow loading avatars [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
On occasions when the avatars load slowly, does it take that long for ALL of them to appear, or do some of them appear right away and others appear slowly? Does there seem to be any consistency (eg, certain users' avatars always load slowly)?

Sorry to ask so many questions, but it'll help me pin down the problem.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#12144 - 10/01/10 02:27 PM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
Originally Posted By: tacit
On occasions when the avatars load slowly, does it take that long for ALL of them to appear, or do some of them appear right away and others appear slowly? Does there seem to be any consistency (eg, certain users' avatars always load slowly)?

Sorry to ask so many questions, but it'll help me pin down the problem.

No problem...happy to help.

I'll take notes next time it happens, because I'm not certain whether what I remember at the moment is real or imaginary.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12390 - 10/13/10 10:04 PM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
I just experienced a slow-loading avatar for the first time since I last posted...

After I clicked "Submit" the first three avatars here loaded immediately, but mine took an additional 5 seconds.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12400 - 10/14/10 03:26 AM Re: Slow loading avatars [Re: artie505]
dkmarsh Offline

Moderator

Registered: 08/04/09

I guess the next thing to determine, then, would be whether or not this happens only in threads to which you haven't previously posted.
_________________________

dkmarsh • member, FineTunedMac Co-op Board of Directors

Top
#12402 - 10/14/10 03:49 AM Re: Slow loading avatars [Re: dkmarsh]
artie505 Online


Registered: 08/04/09
Originally Posted By: dkmarsh
I guess the next thing to determine, then, would be whether or not this happens only in threads to which you haven't previously posted.

Suggestion noted... Thanks. (As you can see from the time between my last two posts, the occurrences have been pretty scarce lately, so it'll likely be some time before I have anything to report.)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12421 - 10/14/10 02:27 PM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
Following up on dkmarsh's suggestion...

I just posted to this thread to which I had previously posted, and slolerner's avatar loaded instantly, but both of mine and joemike's took an additional 8-10 seconds to load.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#12424 - 10/14/10 03:31 PM Re: Slow loading avatars [Re: artie505]
dkmarsh Offline

Moderator

Registered: 08/04/09

Hmm...seems that both you and joemikeb were "currently online" at the time you posted in the linked thread, but slolerner was not. I suppose it's possible that the lag is not actually in the loading of the avatars, but in the loading of /forums/images/moods/default/content.gif (the "online" emoticon which immediately precedes the avatar in the page source)...or in the process by which the software determines that a currently-online viewer is currently online.

Independent test...

Well, that seems to load instantly.
_________________________

dkmarsh • member, FineTunedMac Co-op Board of Directors

Top
#12426 - 10/14/10 07:37 PM Re: Slow loading avatars [Re: dkmarsh]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Originally Posted By: dkmarsh

Hmm...seems that both you and joemikeb were "currently online" at the time you posted in the linked thread, but slolerner was not. I suppose it's possible that the lag is not actually in the loading of the avatars, but in the loading of /forums/images/moods/default/content.gif (the "online" emoticon which immediately precedes the avatar in the page source)...or in the process by which the software determines that a currently-online viewer is currently online.

Independent test...

Well, that seems to load instantly.


That's an interesting hypothesis.

I've looked at the avatars themselves and can find nothing about them that should be slow to load. The avatars are small, the system logs show no undue activity trying to access them, and there's nothing in any error logs that indicates a problem with them. I've just loaded the avatars directly and everything loaded quickly.

The hypothesis that the actual problem is with the "online" indicator is an interesting one. I'm going to keep an eye on how quickly the part of the script that checks for online users loads and see if there's anything in the way it executes that might be taking an undue amount of time. I'll keep you posted!
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#12429 - 10/14/10 11:19 PM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
I'll keep an eye on the "online" indicators and let you know if I learn anything.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#13926 - 01/24/11 10:03 PM Re: Slow loading avatars [Re: artie505]
artie505 Online


Registered: 08/04/09
I'm still experiencing intermittent slow loading of avatars, but I've yet to lock in on an all-inclusive set of circumstances.

I have noticed, though, that when the avatars are slow to load, the "Previous Topic," "Index," and "Next Topic" links at the bottom of the page are sometimes also slow to load.

Edit: Darn... Too many things happen on a (loading) page at the same time! I think I just noticed the "Edit" and other links also loading slowly, too.


Edited by artie505 (01/24/11 10:06 PM)
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top
#14012 - 02/02/11 09:14 PM Re: Slow loading avatars [Re: artie505]
tacit Offline


Registered: 08/03/09
Loc: Portland, Oregon, USA
Weird. Most likely, those elements (the links at the bottom and so on) are slow loading because the loading of the avatars is jamming up the loading of the entire rest of the page. (Those links should be cached, so should load instantly).

It's always frustrating to try to troubleshoot problems you can't replicate. I poked around with this a couple weeks ago and I'll be deuced if I can see anything wrong.
_________________________
Photo gallery, all about me, and more: www.xeromag.com/franklin.html

Top
#14712 - 03/15/11 01:41 AM Re: Slow loading avatars [Re: tacit]
artie505 Online


Registered: 08/04/09
Latest update... It hasn't happened very often lately, but I've noticed that when it does, yours and MacManiac's avatars, both of which, I believe, are externally hosted, load quickly, and the others are the slow to load.
_________________________
The new Great Equalizer is the SEND button.

In Memory Of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Top

Moderator:  alternaut, cyn, dkmarsh