An open community 
of Macintosh users,
for Macintosh users.

FineTunedMac Dashboard widget now available! Download Here

Previous Thread
Next Thread
Print Thread
not eligible for update
#21266 03/28/12 07:34 PM
Joined: Aug 2009
OP Offline

Joined: Aug 2009
I've ran across this error numerous times in the past. (I may have brought this up here before) I have a machine here that has 10.7.0 on it and refuses to accept the 10.7.2 or 10.7.3 combo updaters. It puts up a yellow triangle and says the volume isn't eligible. This is what I would expect if I tried to select a volume with say, a newer version of 10.7 on it than the combo, or a different release like 10.6.

I have googled around repeatedly to try to figure out what exactly the installer is checking to determine the OS version, and found only numerous people with the same problem that all were forced to reinstall the OS. I know there are numerous places the version and build are at. The one I use is /System/Library/CoreServices/SystemVersion.plist, and I suspect that's the one Apple expects apps to use, since they have kept it in text (not binary) plist format. But it's not what the installer is looking at.

Anyone happen to know?


I work for the Department of Redundancy Department
Re: not eligible for update
Virtual1 #21268 03/28/12 08:00 PM
Joined: Aug 2009
Offline

Joined: Aug 2009
Have you tried downloading the updaters as stand-alone .dmg files? And then tried installing same?

I prefer that method (rather than letting the updater do it). Actually, I have to do it that way since I don't have broadband/high-speed Internet connection; so I go a machine with T-base 100 or something similar, download the usually humongous update onto a flash drive, and then bring it home.

Re: not eligible for update
grelber #21269 03/28/12 08:31 PM
Joined: Aug 2009
OP Offline

Joined: Aug 2009
yes I am using the predownloaded images. I use them all the time here, it'd be crazy to be downloading the same 1.5gb updates all the time wink

I also noticed my downloaded 10.7.3 combo's certificate expired on the 23rd, haven't seen that before. tho I have seen it when the computer's clock is set wrong. I assume if I downloaded it again now it would have a new signature on it. (that had nothing to do with the problem)

I have reinstalled 10.7.0 on that one and it now accepts the 10.7.3 update.

On a few occasions I've seen a worse variation on the problem, where the base installer also refuses to run for apparently similar reasons. For THOSE, I have to set aside the system files and do a clean reinstall and import stuff, big hassle. So I'd really like to know what it's looking at.


I work for the Department of Redundancy Department
Re: not eligible for update
Virtual1 #21270 03/28/12 09:06 PM
Joined: Aug 2009
Offline

Joined: Aug 2009
In a few cases where app installs would not work, I had success if I then booted in to Safe Boot and ran the installer from there.

If desperate, it may be worth a try...


Harv
27" i7 iMac (10.13.6), iPhone Xs Max (12.1)

Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: not eligible for update
Pendragon #21271 03/28/12 09:09 PM
Joined: Aug 2009
OP Offline

Joined: Aug 2009
no dice. can't install while booted from another system.


I work for the Department of Redundancy Department
Re: not eligible for update
Virtual1 #21274 03/28/12 09:28 PM
Joined: Aug 2009
Likes: 2
Online

Joined: Aug 2009
Likes: 2
Originally Posted By: Virtual1
no dice. can't install while booted from another system.

Are you saying that Safe Mode is another system, or are you just being obscure about what you're trying to do?


The new Great Equalizer is the SEND button.

In Memory of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: not eligible for update
artie505 #21276 03/28/12 09:55 PM
Joined: Aug 2009
OP Offline

Joined: Aug 2009
I am surrounded by bootable service drives here, including a handful of flash drives. In this case I booted off another hard drive's 10.7.3 service partition and tried to run the 10.7.3 combo updater on the internal hard drive, and got the same results as when trying to run it whilst booted off the internal hard drive.

Unless you were suggesting that safe boot was needed while booted off another os?


I work for the Department of Redundancy Department
Re: not eligible for update
Virtual1 #21277 03/28/12 10:00 PM
Joined: Aug 2009
Likes: 2
Online

Joined: Aug 2009
Likes: 2
> In this case I booted off another hard drive's 10.7.3 service partition and tried to run the 10.7.3 combo updater on the internal hard drive, and got the same results as when trying to run it whilst booted off the internal hard drive.

I think Harv was suggesting that you try to install the Combo on the internal hard drive while it was booted into Safe Mode.


The new Great Equalizer is the SEND button.

In Memory of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: not eligible for update
Virtual1 #21279 03/29/12 01:44 AM
Joined: Aug 2009
Likes: 1
Offline

Joined: Aug 2009
Likes: 1
Any messages in the Console about the problem?


Photo gallery, all about me, and more: www.xeromag.com/franklin.html
Re: not eligible for update
tacit #21281 03/29/12 02:42 AM
Joined: Aug 2009
OP Offline

Joined: Aug 2009
Originally Posted By: tacit
Any messages in the Console about the problem?


heh, I feel kinda silly for not having checked that now... *blush*

maybe next time...


I work for the Department of Redundancy Department
Re: not eligible for update
artie505 #21283 03/29/12 10:02 AM
Joined: Aug 2009
Offline

Joined: Aug 2009
Originally Posted By: artie505
I think Harv was suggesting that you try to install the Combo on the internal hard drive while it was booted into Safe Mode.


Precisely.


Harv
27" i7 iMac (10.13.6), iPhone Xs Max (12.1)

Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: not eligible for update
Virtual1 #21294 03/29/12 04:39 PM
Joined: Sep 2009
Offline

Joined: Sep 2009
Originally Posted By: Virtual1
I've ran across this error numerous times in the past. (I may have brought this up here before) I have a machine here that has 10.7.0 on it and refuses to accept the 10.7.2 or 10.7.3 combo updaters. It puts up a yellow triangle and says the volume isn't eligible. This is what I would expect if I tried to select a volume with say, a newer version of 10.7 on it than the combo, or a different release like 10.6.

I have googled around repeatedly to try to figure out what exactly the installer is checking to determine the OS version, and found only numerous people with the same problem that all were forced to reinstall the OS. I know there are numerous places the version and build are at. The one I use is /System/Library/CoreServices/SystemVersion.plist, and I suspect that's the one Apple expects apps to use, since they have kept it in text (not binary) plist format. But it's not what the installer is looking at.

Anyone happen to know?

Maybe it has nothing to with "version' but rather some other impediment.

Re: not eligible for update
Hal Itosis #21296 03/29/12 04:44 PM
Joined: Aug 2009
Moderator
Offline
Moderator

Joined: Aug 2009
Originally Posted By: Hal Itosis
Maybe it has nothing to with "version' but rather some other impediment.

Yet another reason for tacit's Console suggestion, I'm sure. tongue


alternaut moderator
Re: not eligible for update
alternaut #21298 03/29/12 04:55 PM
Joined: Sep 2009
Offline

Joined: Sep 2009
i didn't indicate otherwise. (did i?)

Re: not eligible for update
Hal Itosis #21299 03/29/12 05:22 PM
Joined: Aug 2009
Moderator
Offline
Moderator

Joined: Aug 2009
Indeed you didn't. But did you have your coffee/tea/favorite drink today? smirk


alternaut moderator
Re: not eligible for update
alternaut #21460 04/08/12 01:37 AM
Joined: Aug 2009
Likes: 2
Online

Joined: Aug 2009
Likes: 2
Originally Posted By: alternaut
Indeed you didn't. But did you have your coffee/tea/favorite drink today? smirk

Apropos of that, Hal's last few posts (over a week ago) were pretty grumpy, and now he's disappeared; I hope he's OK.


The new Great Equalizer is the SEND button.

In Memory of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire
Re: not eligible for update
artie505 #21461 04/08/12 01:40 AM
Joined: Aug 2009
Moderator
Offline
Moderator

Joined: Aug 2009
I sure noticed his absence, and wondered if he's already on his annual Nordic retreat (everything being rather early this year).


alternaut moderator
Re: not eligible for update
alternaut #21462 04/08/12 01:59 AM
Joined: Aug 2009
Likes: 2
Online

Joined: Aug 2009
Likes: 2
I sure hope so, and not a minute too soon, albeit early.


The new Great Equalizer is the SEND button.

In Memory of Harv: Those who can make you believe absurdities can make you commit atrocities. ~Voltaire

Moderated by  alternaut, dkmarsh, joemikeb 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Release build 20200307)
Responsive Width:

PHP: 7.3.24 Page Time: 0.031s Queries: 50 (0.020s) Memory: 0.7907 MB (Peak: 0.9134 MB) Data Comp: Zlib Server Time: 2021-01-20 10:07:46 UTC
Valid HTML 5 and Valid CSS